Bug 116628 - moving opened files tab in the editor is very slow
moving opened files tab in the editor is very slow
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
Macintosh All
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
plan61
: PERFORMANCE, PLAN
: 96658 126270 (view as bug list)
Depends on:
Blocks: 123110
  Show dependency treegraph
 
Reported: 2007-09-25 09:29 UTC by madiot
Modified: 2008-12-22 11:08 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description madiot 2007-09-25 09:29:21 UTC
open 5/10 java files from a java project containing about 150 files.
try to shuffle the tabs, getting the orange outline of the tab is already slow to appear
and moving it to desired location is both slow and imprecise.

i always had this problem for as far as netbeans 4, but now testing in 6beta would have thought something should be done
to address this.
Comment 1 David Simonek 2007-10-08 13:55:25 UTC
*** Issue 96658 has been marked as a duplicate of this issue. ***
Comment 2 Stanislav Aubrecht 2007-11-01 16:14:32 UTC
btw, i noticed that even resizing of the main nb window isn't very smooth either. perhaps it's a general apple jdk issue.
Comment 3 David Simonek 2007-11-30 11:03:11 UTC
Description:
- we need to check glass pane handling, either remove it completely or use faster technique
- consider to get rid of JDK DnD support, we don't need to move windows to other applications, perhaps just checking
user gesture for drag start and tracking movement will be cheaper

Time estimation: 3 man weeks if we decide to rewrite DnD support

 
Comment 4 Stanislav Aubrecht 2008-01-10 11:48:55 UTC
fixed

/cvs/core/windows/src/org/netbeans/core/windows/view/dnd/WindowDnDManager.java,v  <--  WindowDnDManager.java
new revision: 1.28; previous revision: 1.27
done
Checking in EnhancedDragPainter.java;
/cvs/core/windows/src/org/netbeans/core/windows/view/dnd/EnhancedDragPainter.java,v  <--  EnhancedDragPainter.java
new revision: 1.5; previous revision: 1.4
done
Checking in DropTargetGlassPane.java;
/cvs/core/windows/src/org/netbeans/core/windows/view/dnd/DropTargetGlassPane.java,v  <--  DropTargetGlassPane.java
new revision: 1.18; previous revision: 1.17
done
Comment 5 Lukas Hasik 2008-02-07 10:32:54 UTC
*** Issue 126270 has been marked as a duplicate of this issue. ***
Comment 6 Lukas Hasik 2008-02-07 12:43:54 UTC
v


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo