Bug 116578 - [60cat] "no executable location" when setting breakpoint
[60cat] "no executable location" when setting breakpoint
Status: CLOSED DUPLICATE of bug 115033
Product: debugger
Classification: Unclassified
Component: Code
6.x
PC Linux
: P3 (vote)
: TBD
Assigned To: Martin Entlicher
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-24 21:32 UTC by gholmer
Modified: 2010-04-29 09:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gholmer 2007-09-24 21:32:56 UTC
[ JDK VERSION : 1.5.* ]

Using an external copy of Tomcat 6.0 with "attach debugger". Setting a breakpoint in a web app gives this message:

Not able to submit breakpoint LineBreakpoint AtssAction.java : 354, reason: No executable location available at line 354.
Invalid LineBreakpoint AtssAction.java : 354

but line 354 is (split across two lines):

      messages.add("general",
                   new ActionMessage("error.generic", exc.getMessage()));

As soon as I restart Tomcat, the breakpoint badge changes to solid pink, and when I reconnect, there are no errors.

The issue occurs only intermittently.
Comment 1 Roman Ondruska 2007-09-25 08:55:24 UTC
The Sun Javac only creates a location for the first line in multi-line expressions although this is not specified
anywhere. Are you using SUN Javac for the compilation? Is the breakpoint toggled at 354 or 355? Thanks. 
Comment 2 Martin Entlicher 2007-10-08 19:47:35 UTC
Please run NetBeans with following option:
-J-Dorg.netbeans.modules.debugger.jpda.level=400
and when this happens again, please provide the log file where debugging messages are printed. That should help to
identify the problem.
If line 354 is the second line of the expression, then the breakpoint will not work there.
If line 354 is the first line of the expression, then there should not be any problem. Are you able to submit
breakpoints at other lines in that class when it invalidates the breakpoint?
Comment 3 Martin Entlicher 2007-10-08 20:00:12 UTC
I've also added the class name into the error message, for reference:

/shared/data/ccvs/repository/debuggerjpda/src/org/netbeans/modules/debugger/jpda/breakpoints/Bundle.properties,v  <-- 
Bundle.properties
new revision: 1.18; previous revision: 1.17

/shared/data/ccvs/repository/debuggerjpda/src/org/netbeans/modules/debugger/jpda/breakpoints/LineBreakpointImpl.java,v 
<--  LineBreakpointImpl.java
new revision: 1.45; previous revision: 1.44
Comment 4 Martin Entlicher 2007-10-18 17:33:51 UTC
Please try on recent 6.0 build (or upcomming beta2), breakpoints validity works fine for us.
If there are still some problems, they should be apparent from extended log generated after
-J-Dorg.netbeans.modules.debugger.jpda.level=400 option is used.
Resolving as works for me.
Comment 5 Martin Entlicher 2007-10-18 17:54:30 UTC
Maybe there's really some subtle problem occuring under some specific circumstances. I've found issue #115033.
Comment 6 Martin Entlicher 2007-10-18 17:55:39 UTC
Resolving as a dupl. of older issue #115033. Please add any further comments/logs there. Thanks.

*** This issue has been marked as a duplicate of 115033 ***
Comment 7 Quality Engineering 2010-04-29 09:35:18 UTC
Verified ... and Closing all issues resolved into NetBeans 6.7 and earlier.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo