Bug 116370 - fail to deploy web module with struts through netbeans
fail to deploy web module with struts through netbeans
Status: RESOLVED WORKSFORME
Product: javaee
Classification: Unclassified
Component: EAR
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@javaee
: SPACE_IN_PATH
: 121240 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-21 20:06 UTC by jialu
Modified: 2008-02-14 00:34 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
glass fish server.log (44.19 KB, text/plain)
2007-12-04 02:34 UTC, jialu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jialu 2007-09-21 20:06:31 UTC
If an enterprise application has web module with struts, it fails to deploy the web module when the enterprise 
application is deployed through netbeans 6.
To reproduce: 9/20 nightly build is installed. Create a new enterprise application with ejb module and web module, and 
choose struts in the web module. Deploy this project, you can find following exception in glassfish server.log file, 
though it shows that the application is deloyed successfully in netbeans.
#|2007-09-20T18:57:57.602-0700|SEVERE|sun-
appserver9.1|org.apache.struts.action.ActionServlet|_ThreadID=15;_ThreadName=httpWorkerThread-4848-
0;_RequestID=97fd0dd5-ca6d-4c18-be69-d3d7a2f7912a;|Parsing error processing resource path /WEB-INF/struts-config.xml
java.util.zip.ZipException: The system cannot find the path specified
	at java.util.zip.ZipFile.open(Native Method)
	at java.util.zip.ZipFile.<init>(ZipFile.java:203)
	at java.util.jar.JarFile.<init>(JarFile.java:132)
	at java.util.jar.JarFile.<init>(JarFile.java:70)
	at sun.net.www.protocol.jar.URLJarFile.<init>(URLJarFile.java:56)
	at sun.net.www.protocol.jar.URLJarFile.getJarFile(URLJarFile.java:41)
	at sun.net.www.protocol.jar.JarFileFactory.get(JarFileFactory.java:63)
	at sun.net.www.protocol.jar.JarURLConnection.connect(JarURLConnection.java:102)
	at sun.net.www.protocol.jar.JarURLConnection.getInputStream(JarURLConnection.java:124)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityManager.setupCurrentEntity(XMLEntityManager.java:973)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityManager.startEntity(XMLEntityManager.java:905)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityManager.startDTDEntity(XMLEntityManager.java:872)
	at com.sun.org.apache.xerces.internal.impl.XMLDTDScannerImpl.setInputSource(XMLDTDScannerImpl.java:282)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$DTDDispatcher.dispatch
(XMLDocumentScannerImpl.java:1021)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument
(XMLDocumentFragmentScannerImpl.java:368)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:834)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:764)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:148)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1242)
	at org.apache.commons.digester.Digester.parse(Digester.java:1572)
	at org.apache.struts.action.ActionServlet.parseModuleConfigFile(ActionServlet.java:738)
	at org.apache.struts.action.ActionServlet.initModuleConfig(ActionServlet.java:687)
	at org.apache.struts.action.ActionServlet.init(ActionServlet.java:333)
	at javax.servlet.GenericServlet.init(GenericServlet.java:254)
	at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1178)
	at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1007)
	at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4800)
	at org.apache.catalina.core.StandardContext.start(StandardContext.java:5188)
	at com.sun.enterprise.web.WebModule.start(WebModule.java:327)
	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:973)
	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:957)
	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:688)
	at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:1581)
	at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:1222)
	at com.sun.enterprise.web.WebContainer.loadJ2EEApplicationWebModules(WebContainer.java:1147)
	at com.sun.enterprise.server.TomcatApplicationLoader.doLoad(TomcatApplicationLoader.java:141)
	at com.sun.enterprise.server.AbstractLoader.load(AbstractLoader.java:244)
	at com.sun.enterprise.server.ApplicationManager.applicationDeployed(ApplicationManager.java:336)
	at com.sun.enterprise.server.ApplicationManager.applicationDeployed(ApplicationManager.java:210)
	at com.sun.enterprise.server.ApplicationManager.applicationDeployed(ApplicationManager.java:645)
	at com.sun.enterprise.admin.event.AdminEventMulticaster.invokeApplicationDeployEventListener
(AdminEventMulticaster.java:928)
	at com.sun.enterprise.admin.event.AdminEventMulticaster.handleApplicationDeployEvent
(AdminEventMulticaster.java:912)
	at com.sun.enterprise.admin.event.AdminEventMulticaster.processEvent(AdminEventMulticaster.java:461)
	at com.sun.enterprise.admin.event.AdminEventMulticaster.multicastEvent(AdminEventMulticaster.java:176)
	at com.sun.enterprise.admin.server.core.DeploymentNotificationHelper.multicastEvent
(DeploymentNotificationHelper.java:308)
	at com.sun.enterprise.deployment.phasing.DeploymentServiceUtils.multicastEvent(DeploymentServiceUtils.java:226)
	at com.sun.enterprise.deployment.phasing.ServerDeploymentTarget.sendStartEvent(ServerDeploymentTarget.java:298)
	at com.sun.enterprise.deployment.phasing.ApplicationStartPhase.runPhase(ApplicationStartPhase.java:132)
	at com.sun.enterprise.deployment.phasing.DeploymentPhase.executePhase(DeploymentPhase.java:108)
	at com.sun.enterprise.deployment.phasing.PEDeploymentService.executePhases(PEDeploymentService.java:919)
	at com.sun.enterprise.deployment.phasing.PEDeploymentService.start(PEDeploymentService.java:591)
	at com.sun.enterprise.deployment.phasing.PEDeploymentService.start(PEDeploymentService.java:635)
	at com.sun.enterprise.admin.mbeans.ApplicationsConfigMBean.start(ApplicationsConfigMBean.java:744)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at com.sun.enterprise.admin.MBeanHelper.invokeOperationInBean(MBeanHelper.java:375)
	at com.sun.enterprise.admin.MBeanHelper.invokeOperationInBean(MBeanHelper.java:358)
	at com.sun.enterprise.admin.config.BaseConfigMBean.invoke(BaseConfigMBean.java:464)
	at com.sun.jmx.mbeanserver.DynamicMetaDataImpl.invoke(DynamicMetaDataImpl.java:213)
	at com.sun.jmx.mbeanserver.MetaDataImpl.invoke(MetaDataImpl.java:220)
	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:815)
	at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:784)
	at sun.reflect.GeneratedMethodAccessor12.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at com.sun.enterprise.admin.util.proxy.ProxyClass.invoke(ProxyClass.java:90)
	at $Proxy1.invoke(Unknown Source)
	at com.sun.enterprise.admin.server.core.jmx.SunoneInterceptor.invoke(SunoneInterceptor.java:304)
	at com.sun.enterprise.interceptor.DynamicInterceptor.invoke(DynamicInterceptor.java:174)
	at com.sun.enterprise.admin.jmx.remote.server.callers.InvokeCaller.call(InvokeCaller.java:69)
	at com.sun.enterprise.admin.jmx.remote.server.MBeanServerRequestHandler.handle
(MBeanServerRequestHandler.java:155)
	at com.sun.enterprise.admin.jmx.remote.server.servlet.RemoteJmxConnectorServlet.processRequest
(RemoteJmxConnectorServlet.java:122)
	at com.sun.enterprise.admin.jmx.remote.server.servlet.RemoteJmxConnectorServlet.doPost
(RemoteJmxConnectorServlet.java:193)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:738)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:831)
	at org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:411)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:317)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:198)
	at org.netbeans.modules.web.monitor.server.MonitorFilter.doFilter(MonitorFilter.java:174)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:230)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:198)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:288)
	at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:271)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:202)
	at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
	at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
	at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:206)
	at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
	at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:150)
	at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
	at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
	at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:270)
	at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:637)
	at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:568)
	at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:813)
	at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:339)
	at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:261)
	at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:212)
	at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265)
	at com.sun.enterprise.web.connector.grizzly.WorkerThreadImpl.run(WorkerThreadImpl.java:116)
|#]
Comment 1 Tomas Mysik 2007-09-24 10:01:21 UTC
I'm not able to reproduce this issue. Can you provide more information please? Have you seen Welcome page in your 
browser after running the EAR application? Have you tried to reproduce it with development version of NetBeans? Which 
JDK do you have? Any other hints how to reproduce? Thank you.

Product Version: NetBeans IDE Dev (Build 070924)
Java: 1.6.0_02; Java HotSpot(TM) Client VM 1.6.0_02-b05
System: Linux version 2.6.22-gentoo-r6 running on i386; UTF-8; cs_CZ (nb)
GlassFish V2 b58g
Comment 2 Tomas Mysik 2007-10-01 13:48:20 UTC
Any progress please? Thank you.
Comment 3 Tomas Mysik 2007-10-08 13:33:24 UTC
No response so closing. Reopen if the problem still exists. Thank you.
Comment 4 jialu 2007-12-04 02:34:27 UTC
Created attachment 53809 [details]
glass fish server.log
Comment 5 jialu 2007-12-04 02:36:13 UTC
Hi,
I had download netbean 6.0 and It looks the problem is still there. The application fails to deploy and I could not 
seen the web pages. I had tried it at ohter development version of NetBeans. I got the same problem. I use Jdk 
1.5.0_12 for netbeans and glassfish. 
To reproduce:
1. Create an Enterprise Application with a EJB module and a Web application module.
2. After the Enterprise Application is created, add Struts1.2.9 as used frameworks in the web application project 
properties panel.
3. deploy the Enterprise Application to glassfish.
4. the netbeans shows the applicaion deployed successfully. But, it actually fail to deploye at glassfish and you can 
find the following excetion in glassfish server.log.

The error message in server.log:
[#|2007-12-03T18:09:20.553-0800|SEVERE|sun-
appserver9.1|org.apache.struts.action.ActionServlet|_ThreadID=15;_ThreadName=httpWorkerThread-4848-
1;_RequestID=6949d268-07cf-4d73-86c1-ce24c62b23b5;|Parsing error processing resource path /WEB-INF/struts-config.xml
java.util.zip.ZipException: The system cannot find the path specified
	at java.util.zip.ZipFile.open(Native Method)
	at java.util.zip.ZipFile.<init>(ZipFile.java:203)
	at java.util.jar.JarFile.<init>(JarFile.java:132)
	at java.util.jar.JarFile.<init>(JarFile.java:70)
	at sun.net.www.protocol.jar.URLJarFile.<init>(URLJarFile.java:56)
	at sun.net.www.protocol.jar.URLJarFile.getJarFile(URLJarFile.java:41)
	at sun.net.www.protocol.jar.JarFileFactory.get(JarFileFactory.java:63)
	at sun.net.www.protocol.jar.JarURLConnection.connect(JarURLConnection.java:102)
	at sun.net.www.protocol.jar.JarURLConnection.getInputStream(JarURLConnection.java:124)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityManager.setupCurrentEntity(XMLEntityManager.java:973)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityManager.startEntity(XMLEntityManager.java:905)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityManager.startDTDEntity(XMLEntityManager.java:872)
	at com.sun.org.apache.xerces.internal.impl.XMLDTDScannerImpl.setInputSource(XMLDTDScannerImpl.java:282)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$DTDDispatcher.dispatch
(XMLDocumentScannerImpl.java:1021)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument
(XMLDocumentFragmentScannerImpl.java:368)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:834)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:764)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:148)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1242)
	at org.apache.commons.digester.Digester.parse(Digester.java:1572)
	at org.apache.struts.action.ActionServlet.parseModuleConfigFile(ActionServlet.java:738)
	at org.apache.struts.action.ActionServlet.initModuleConfig(ActionServlet.java:687)
	at org.apache.struts.action.ActionServlet.init(ActionServlet.java:333)
	at javax.servlet.GenericServlet.init(GenericServlet.java:254)
	at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1178)
	at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1007)
	at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4800)
	at org.apache.catalina.core.StandardContext.start(StandardContext.java:5188)
	at com.sun.enterprise.web.WebModule.start(WebModule.java:327)
	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:973)
	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:957)
	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:688)
	at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:1581)
	at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:1222)
	at com.sun.enterprise.web.WebContainer.loadJ2EEApplicationWebModules(WebContainer.java:1147)
	at com.sun.enterprise.server.TomcatApplicationLoader.doLoad(TomcatApplicationLoader.java:141)
	at com.sun.enterprise.server.AbstractLoader.load(AbstractLoader.java:244)
	at com.sun.enterprise.server.ApplicationManager.applicationDeployed(ApplicationManager.java:336)
	at com.sun.enterprise.server.ApplicationManager.applicationDeployed(ApplicationManager.java:210)
	at com.sun.enterprise.server.ApplicationManager.applicationDeployed(ApplicationManager.java:645)
	at com.sun.enterprise.admin.event.AdminEventMulticaster.invokeApplicationDeployEventListener
(AdminEventMulticaster.java:928)
	at com.sun.enterprise.admin.event.AdminEventMulticaster.handleApplicationDeployEvent
(AdminEventMulticaster.java:912)
	at com.sun.enterprise.admin.event.AdminEventMulticaster.processEvent(AdminEventMulticaster.java:461)
	at com.sun.enterprise.admin.event.AdminEventMulticaster.multicastEvent(AdminEventMulticaster.java:176)
	at com.sun.enterprise.admin.server.core.DeploymentNotificationHelper.multicastEvent
(DeploymentNotificationHelper.java:308)
	at com.sun.enterprise.deployment.phasing.DeploymentServiceUtils.multicastEvent(DeploymentServiceUtils.java:226)
	at com.sun.enterprise.deployment.phasing.ServerDeploymentTarget.sendStartEvent(ServerDeploymentTarget.java:298)
	at com.sun.enterprise.deployment.phasing.ApplicationStartPhase.runPhase(ApplicationStartPhase.java:132)
	at com.sun.enterprise.deployment.phasing.DeploymentPhase.executePhase(DeploymentPhase.java:108)
	at com.sun.enterprise.deployment.phasing.PEDeploymentService.executePhases(PEDeploymentService.java:919)
	at com.sun.enterprise.deployment.phasing.PEDeploymentService.start(PEDeploymentService.java:591)
	at com.sun.enterprise.deployment.phasing.PEDeploymentService.start(PEDeploymentService.java:635)
	at com.sun.enterprise.admin.mbeans.ApplicationsConfigMBean.start(ApplicationsConfigMBean.java:744)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at com.sun.enterprise.admin.MBeanHelper.invokeOperationInBean(MBeanHelper.java:375)
	at com.sun.enterprise.admin.MBeanHelper.invokeOperationInBean(MBeanHelper.java:358)
	at com.sun.enterprise.admin.config.BaseConfigMBean.invoke(BaseConfigMBean.java:464)
	at com.sun.jmx.mbeanserver.DynamicMetaDataImpl.invoke(DynamicMetaDataImpl.java:213)
	at com.sun.jmx.mbeanserver.MetaDataImpl.invoke(MetaDataImpl.java:220)
	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:815)
	at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:784)
	at sun.reflect.GeneratedMethodAccessor12.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at com.sun.enterprise.admin.util.proxy.ProxyClass.invoke(ProxyClass.java:90)
	at $Proxy1.invoke(Unknown Source)
	at com.sun.enterprise.admin.server.core.jmx.SunoneInterceptor.invoke(SunoneInterceptor.java:304)
	at com.sun.enterprise.interceptor.DynamicInterceptor.invoke(DynamicInterceptor.java:174)
	at com.sun.enterprise.admin.jmx.remote.server.callers.InvokeCaller.call(InvokeCaller.java:69)
	at com.sun.enterprise.admin.jmx.remote.server.MBeanServerRequestHandler.handle
(MBeanServerRequestHandler.java:155)
	at com.sun.enterprise.admin.jmx.remote.server.servlet.RemoteJmxConnectorServlet.processRequest
(RemoteJmxConnectorServlet.java:122)
	at com.sun.enterprise.admin.jmx.remote.server.servlet.RemoteJmxConnectorServlet.doPost
(RemoteJmxConnectorServlet.java:193)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:738)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:831)
	at org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:411)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:317)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:198)
	at org.netbeans.modules.web.monitor.server.MonitorFilter.doFilter(MonitorFilter.java:196)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:230)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:198)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:288)
	at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:271)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:202)
	at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
	at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
	at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:206)
	at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
	at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:150)
	at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
	at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
	at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:270)
	at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:637)
	at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:568)
	at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:813)
	at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:339)
	at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:261)
	at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:212)
	at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265)
	at com.sun.enterprise.web.connector.grizzly.WorkerThreadImpl.run(WorkerThreadImpl.java:116)
|#]

Thank you.
Jia

 
Comment 6 Radim Roska 2007-12-04 11:12:20 UTC
i've just tried to reproduce this issue..but it works for me.

Please specify what OS are you using. I guess you are deploying project on glassfish bundled with nb60, am i correct?

Have you edited struts-config.xml somehow? Have you tried to run this project? That exception you've got can come from
another project that is deployed to the server..but this could be possible only during starting. So another "run" 
operation of your project (while server is running) would be without any exception or error.

Thanks
Comment 7 jialu 2007-12-04 22:10:03 UTC
The OS is Windows XP Service Pack2. Yes, I deploy project on glassfish bundled with nb60. I did not modify struts-
config.xml. The glassfish is clean and no other project is deployed in my test. If the ear is deployed though the web 
admin console, it works just fine and no exceptions. Only when the ear is deployed through netbeans IDE, I got problem.
If you look at the exception, it is "java.util.zip.ZipException". Why does it read struts-config.xml from zip format? 
the webproject has already been expanded. 
Thanks
   
Comment 8 Radim Roska 2007-12-07 12:10:06 UTC
Thank you for answer..

It looks this issue is windows specific. I've finally reproduced it on windows pc..We will look at it..

Thanks
Comment 9 David Konecny 2007-12-11 13:51:43 UTC
This problem happens only if EAR application is on path containing spaces. So workaround is to create project in
different folder which does not contain spaces.

We tested the scenario on Unix and it worked fine so just confirming it is Windows specific.

phejl suggests to pass this to Vince for evaluation. Disabling directory deployment also resolved the issue.
Comment 10 Vince Kraemer 2008-01-06 17:14:15 UTC
opened issue on GF  https://glassfish.dev.java.net/issues/show_bug.cgi?id=3977
Comment 11 Vince Kraemer 2008-01-08 17:29:38 UTC
*** Issue 121240 has been marked as a duplicate of this issue. ***
Comment 12 Vince Kraemer 2008-02-14 00:01:38 UTC
config: nb 6.1 (recent clone/pull). gf v2.1 (b20).

I was able to create an app with struts and deploy it... even though there was a space in the path leading to the
deployment directory....

Marking as 'worksforme', since I did not make any changes to accomplish this.
Comment 13 David Konecny 2008-02-14 00:15:31 UTC
I'm interpreting what you are saying that problem was fixed in Glassfish 2.1.
Comment 14 Vince Kraemer 2008-02-14 00:34:20 UTC
that is what it looks like


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo