Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 116104 - reconsider a deep status check before commit
reconsider a deep status check before commit
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
6.x
All All
: P3 with 1 vote (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
PLAN
:
: 118832 (view as bug list)
Depends on:
Blocks: 180634
  Show dependency treegraph
 
Reported: 2007-09-20 09:23 UTC by Tomas Stupka
Modified: 2013-04-09 14:17 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Stupka 2007-09-20 09:23:28 UTC
otherwise it may happen the externally changed files won't be included.
Comment 1 Peter Pis 2007-10-14 19:50:02 UTC
*** Issue 118832 has been marked as a duplicate of this issue. ***
Comment 2 Tomas Stupka 2007-10-24 10:56:06 UTC
i've changed the commit dialog so that it checks and refreshes the status for all files on the disk belonging to the
given context before building up the files list. This way should be also external changes (coming outside of the IDE)
always included. An explicit status refresh from the versionig view is no more necessary. 

the old behavior was kept because this was no minor change and i'm not sure about all the impacts it may have  -
performance, ... . 

The new implementation works only with the commandline switch 
-J-Dnetbeans.subversion.commit.deepStatusRefresh=true

rdelaplante:
it would be nice if you could give it a try in the next days (will be included in the tomorrows build) so we still may
make some fixes or tweaks if it shouldn't fit your needs.

thanks

Checking in client/parser/ParserSvnStatus.java;
/cvs/subversion/main/src/org/netbeans/modules/subversion/client/parser/ParserSvnStatus.java,v  <--  ParserSvnStatus.java
new revision: 1.3; previous revision: 1.2
done
Checking in ui/commit/CommitAction.java;
/cvs/subversion/main/src/org/netbeans/modules/subversion/ui/commit/CommitAction.java,v  <--  CommitAction.java
new revision: 1.72; previous revision: 1.71
done
Comment 3 rdelaplante 2007-10-24 13:30:02 UTC
tstupka: Thanks for the commit.  Which ticket of mine is this related to?  119375?    I'm currently under pressure to
finish a project by Friday so I will have to look at this after I'm done.  It will require that I re-install the IDE. 
Thanks.
Comment 4 Tomas Stupka 2007-10-24 14:06:11 UTC
oops. my fault. was actually meant for somebody else...
Comment 5 Tomas Stupka 2007-10-24 14:08:11 UTC
this one is related to issue #117697

21croissants:
it would be nice if you could give it a try in the next days (will be included in the tomorrows build) so we still may
make some fixes or tweaks if it shouldn't fit your needs.
Comment 6 igelei 2008-06-23 20:52:29 UTC
This bug does still exist in Netbeans 6.1. Hope it gets fixed soon.
Comment 7 Tomas Stupka 2008-06-23 21:23:56 UTC
> This bug does still exist
elaborate please. Unfortunately, it's not evident enough what exactly you are referring to...


Comment 8 Ondrej Vrabec 2010-02-03 01:51:32 UTC
What about this:
We could leave the deep status check DISABLED if the commit was invoked from the versioning view or the diff (files are already known)
We could turn the deep status check ON if the commit was invoked from the projects view, files view, etc.

This way the users who abide by our recommended workflow (i.e. Status -> Diff -> Commit or Status -> Diff) won't be bothered with the long commit preparation and the others will have to wait.
Comment 9 Ondrej Vrabec 2010-02-15 01:59:06 UTC
fix: http://hg.netbeans.org/cdev/rev/73abaaf01ff5
Comment 10 Quality Engineering 2010-02-16 21:48:34 UTC
Integrated into 'main-golden', will be available in build *201002170200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/73abaaf01ff5
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #116104 - reconsider a deep status check before commit
deep status refresh enabled by default, but disabled for commits from diff and versioning views
Comment 11 Fabio_Silva 2013-04-09 13:53:49 UTC
I do not see how waiting for 30 min to commit a large project would be considered an enhancement. 

External modifications should not be considered the default behavior. Deepstatusrefresh should be reverted to false in ALL views, unless you configure your IDE to check the files.

If you're using a IDE, its expected that you use that for the entire project. I cant imagine any use case where you have to update only half of your project in IDE.

I was using the flag deepstatusrefresh to false in my netbeans configuration, but that is not working anymore since the last svn module upgrade, so i have to wait for ages to commit.
Comment 12 Ondrej Vrabec 2013-04-09 14:17:25 UTC
> I was using the flag deepstatusrefresh to false in my netbeans configuration,
> but that is not working anymore since the last svn module upgrade, so i have to
> wait for ages to commit.
works for me both in daily builds and and 7.3 release: -J-Dnetbeans.subversion.commit.deepStatusRefresh=false
I suggest you attach your IDE log and make a profiler snapshot so i can analyze it a bit.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo