Bug 115474 - I18N - problem with encoding format
I18N - problem with encoding format
Status: RESOLVED INVALID
Product: java
Classification: Unclassified
Component: Freeform
6.x
Other Windows XP
: P2 (vote)
: 6.x
Assigned To: Milan Kubec
issues@java
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 15:57 UTC by yeradis
Modified: 2008-01-07 12:36 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
this files is not rendered correct with RC1 (98 bytes, text/plain)
2007-11-09 08:54 UTC, thulin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yeradis 2007-09-13 15:57:58 UTC
there is a problem with the enconding format in the editor
is not showing spanish characters i´m using UTF-8 and when editing is ok but when submit changes to svn and then
download changes from svn the special character is replaced with garbage BUT ONLY INSIDE NETBEANS EDITOR not outside
like using Notepad on windows or watching direcly in the svn server repository
Comment 1 Vitezslav Stejskal 2007-09-13 16:12:15 UTC
Ok, what is your encoding for the project? Right-click project node -> properties -> Sources -> Encoding (right at the
bottom)? Is it UTF-8? Also, what file type are you editing? And third, what is your environment (OS, JDK, Netbeans
build, ect) and especially what is the default text encoding in your OS? Thanks a lot.
Comment 2 Vitezslav Stejskal 2007-09-21 10:32:20 UTC
Could you please answer the questions above? We need your help in order to be able to diagnose the problem. Thank you
very much indeed
Comment 3 thulin 2007-11-09 08:52:54 UTC
Open the attached file in an ant based project with latest daily build (071109-RC1?). It would display "boxes".

System.out.println("���");

Opening the source file with Beta 2 it looks fine. If this is a bug, it is a showstopper, therefore I changed priority
to P1.

The enconding for the project it UTF-8. If the Bug.java is opened with RC1 but not within an ant based project, it looks ok.
Comment 4 thulin 2007-11-09 08:54:03 UTC
Created attachment 52778 [details]
this files is not rendered correct with RC1
Comment 5 Marian Mirilovic 2007-11-09 09:43:35 UTC
I can't reproduce (Ubuntu, RC1, JDK 1.6.0_04)
Comment 6 Ken Frank 2007-11-09 15:14:30 UTC
thulin,

here are some questions that can help us understand more and emulate
your exact situation so we can see the specific problem and investigate
fix:

1. there have been some recent fixes to encoding handling related
to freeform projects (including those with ant scripts)

could you try using latest daily build ?

2. also, is the project based on code from another previous netbeans
or from other code ?  

if its from other code, was the other code created when you were
in a non utf-8 spanish locale; since on windows there is not utf-8
locale per se.

3. and what regional settings are being used - what is the choice
of locale for the 1st and 3rd tabs of the regional settings ?

4.  could you try creating some java file in a new project
(not with ant script or from existing sources) and then do your other steps
with svn and 
see if the characters show ok ?

that is, after you put the files in project into svn and then edit and
commit back, and then bring back into editor.

5. finally, can you tell the steps you do in this, esp steps of project
creation and how/when you put the project into svn and the other
steps related to svn and these files ? it will help us to emulate
the problem you are seeing.

ken.frank@sun.com
Comment 7 Milan Kubec 2008-01-04 08:55:40 UTC
Please provide requested info, otherwise the issue will be closed. Thanks.
Comment 8 Milan Kubec 2008-01-07 12:36:29 UTC
As reporter wrote privately the issue can be closed. If somebody is able to reproduce please reopen and provide test case.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo