Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 114832 - 100% Pure Java SVN Lib = svn.exe free
100% Pure Java SVN Lib = svn.exe free
Status: RESOLVED DUPLICATE of bug 75339
Product: versioncontrol
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
http://svnkit.com/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 02:11 UTC by diegovivo
Modified: 2007-09-06 08:58 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description diegovivo 2007-09-06 02:11:42 UTC
This lib can make netbeans have native svn support 
without installation of any other program.
It make the concept out of the box stronger.
I think it's not hard to change svn plugin to make lib calls instead exe calls
This lib is used by 

SmartSVN - Standalone Pure Java Subversion GUI Client. 
IntelliJ IDEA - Java IDE developed by JetBrains. 
TeamCity - Collaborative Team Environment developed by JetBrains.. 
JDeveloper - Oracle's Java IDE Subversion integration. 
FishEye - Powerful Source Repository Tracking and Analyzing tool. 
Syncro SVN Client - Standalone Java Subversion GUI Client. 
<oXygen/> - XML Editor and XSLT Debugger. 
Subclipse - Eclipse Subversion plugin. 
Pulse - Automated Build Server. 
locutor - Innovative Document Management System (DMS). 
Svn4Ant - Ant Subversion integration that makes use SVNKit. 
Subversive - Eclipse Subversion plugin developed by Polarion. 
SVN Web Client - Subversion Web Client developed by Polarion. 
Sventon - Pure Java Subversion repository web browser. 
TrackStudio Enterprise - Hierarchical issue tracking and bug tracking system. 
Atlassian JIRA - Bug tracking system (Subversion plugin page). 
Shotoku - Content management framework, developed at JBoss labs. 
Kosmos - Software project monitoring portlets, developed at JBoss labs. 
VCS Report - generates statistic on repository, supports major Java IDEs. 

So why netbeans can enter in this list.

thanks
regards
Comment 1 Peter Pis 2007-09-06 08:58:15 UTC

*** This issue has been marked as a duplicate of 75339 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo