Bug 114535 - Project manipulation causes deadlock
Project manipulation causes deadlock
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Andrei Badea
issues@javaee
beta1fix
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-03 15:44 UTC by Petr Hejl
Modified: 2007-09-26 02:51 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump 1 (29.39 KB, application/octet-stream)
2007-09-03 15:45 UTC, Petr Hejl
Details
thread dump 2 (26.47 KB, application/octet-stream)
2007-09-03 15:46 UTC, Petr Hejl
Details
Patch to add visualweb/complib as a friend module (853 bytes, text/plain)
2007-09-26 02:47 UTC, _ edwingo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Hejl 2007-09-03 15:44:18 UTC
Steps to reproduce:
1) create web project with glassfish server (for example)
2) open project properties, change server to tomcat
3) ok and (usually) deadlock

Deadlock is met on project mutex and project childer mutex afaik. The issue is reproducible on builds since the 30th of
August.

I will attach two different thread dumps indicating the same deadlock.
Comment 1 Petr Hejl 2007-09-03 15:45:23 UTC
Created attachment 47991 [details]
thread dump 1
Comment 2 Petr Hejl 2007-09-03 15:46:04 UTC
Created attachment 47992 [details]
thread dump 2
Comment 3 Alexander Simon 2007-09-03 16:43:19 UTC
fixed

CVS log:

Checking in ModelSupport.java;
/shared/data/ccvs/repository/cnd/modelimpl/src/org/netbeans/modules/cnd/modelimpl/platform/ModelSupport.java,v  <-- 
ModelSupport.java
new revision: 1.25; previous revision: 1.24
done
Comment 4 Petr Hejl 2007-09-04 09:58:47 UTC
No change in behaviour. Still the same deadlock.
Comment 5 Petr Hejl 2007-09-04 10:12:14 UTC
The issue probably arrives with the implementation of the fix for issue 91291.
Comment 6 Alexander Simon 2007-09-04 10:16:54 UTC
Could you provide new stack?
Comment 7 Jiri Skrivanek 2007-09-04 10:21:05 UTC
It is also 100% reproducable when you add Struts or JSF framework in project properties dialog and click OK.
Comment 8 Vladimir Kvashin 2007-09-04 10:30:13 UTC
I don't see any connection between the issue and the C/C++ Development Pack.
Do you?
Comment 9 Andrei Badea 2007-09-04 15:35:08 UTC
Will be addressed in the Java project types.
Comment 10 Andrei Badea 2007-09-04 15:38:21 UTC
Beta stopper.
Comment 11 Andrei Badea 2007-09-04 17:57:07 UTC
Too hard to fix for beta. Will be temporarily fixed by removing the fix of issue 91291 in all project types and then
downgraded to P2.

Checking in j2ee/clientproject/src/org/netbeans/modules/j2ee/clientproject/ui/customizer/CustomizerProviderImpl.java;
/cvs/j2ee/clientproject/src/org/netbeans/modules/j2ee/clientproject/ui/customizer/CustomizerProviderImpl.java,v  <-- 
CustomizerProviderImpl.java
new revision: 1.9; previous revision: 1.8
done
Checking in j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/ui/customizer/CustomizerProviderImpl.java;
/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/ui/customizer/CustomizerProviderImpl.java,v  <-- 
CustomizerProviderImpl.java
new revision: 1.17; previous revision: 1.16
done
Checking in java/j2seproject/src/org/netbeans/modules/java/j2seproject/ui/customizer/CustomizerProviderImpl.java;
/cvs/java/j2seproject/src/org/netbeans/modules/java/j2seproject/ui/customizer/CustomizerProviderImpl.java,v  <-- 
CustomizerProviderImpl.java
new revision: 1.14; previous revision: 1.13
done
Checking in web/project/src/org/netbeans/modules/web/project/ui/customizer/CustomizerProviderImpl.java;
/cvs/web/project/src/org/netbeans/modules/web/project/ui/customizer/CustomizerProviderImpl.java,v  <-- 
CustomizerProviderImpl.java
new revision: 1.18; previous revision: 1.17
done
Comment 12 Milan Kubec 2007-09-05 11:46:41 UTC
I've reviewed the commit and agree with it.
Comment 13 Tomas Zezula 2007-09-05 12:19:17 UTC
Seems good, feel free to integrate.
Comment 14 Andrei Badea 2007-09-05 12:39:54 UTC
Integrated in release60_beta1.

Checking in j2ee/clientproject/src/org/netbeans/modules/j2ee/clientproject/ui/customizer/CustomizerProviderImpl.java;
/cvs/j2ee/clientproject/src/org/netbeans/modules/j2ee/clientproject/ui/customizer/CustomizerProviderImpl.java,v  <-- 
CustomizerProviderImpl.java
new revision: 1.8.2.1; previous revision: 1.8
done
Checking in j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/ui/customizer/CustomizerProviderImpl.java;
/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/ui/customizer/CustomizerProviderImpl.java,v  <-- 
CustomizerProviderImpl.java
new revision: 1.16.2.1; previous revision: 1.16
done
Checking in java/j2seproject/src/org/netbeans/modules/java/j2seproject/ui/customizer/CustomizerProviderImpl.java;
/cvs/java/j2seproject/src/org/netbeans/modules/java/j2seproject/ui/customizer/CustomizerProviderImpl.java,v  <-- 
CustomizerProviderImpl.java
new revision: 1.13.2.1; previous revision: 1.13
done
Checking in web/project/src/org/netbeans/modules/web/project/ui/customizer/CustomizerProviderImpl.java;
/cvs/web/project/src/org/netbeans/modules/web/project/ui/customizer/CustomizerProviderImpl.java,v  <-- 
CustomizerProviderImpl.java
new revision: 1.17.2.1; previous revision: 1.17
done
Comment 15 Petr Jiricka 2007-09-06 10:00:26 UTC
Shouldn't we close this issue (as it is fixed), and rather reopen issues 91291 and 114345, which are currently NOT fixed?
Comment 16 Milan Kubec 2007-09-06 10:47:05 UTC
Well, issue #91291 is fixed because it was about how project properties are saved and now there is API to save project
properties outside of AWT thread, so we should probably create new issue for j2seproject.
Comment 17 Tomas Zezula 2007-09-06 10:54:59 UTC
j2seproject, why? As far as I know it's a generic problem of the new API contract affecting all project types which want
to use this new API, the report came to web project. I am for reopening of the issue #91291.
Comment 18 Jiri Skrivanek 2007-09-07 10:38:34 UTC
Definitely this issue is fixed in beta1. No more deadlocks.
Comment 19 Jiri Skrivanek 2007-09-07 10:38:51 UTC
Verified in NB 6.0 Beta 1 (Build 200709070000).
Comment 20 Andrei Badea 2007-09-19 14:28:36 UTC
I don't consider this a problem of the API contract, but of the project types. Thus I'm reopening this issue (as the
beta 1 fix was just a temporary fix).
Comment 21 Milan Kubec 2007-09-19 14:56:31 UTC
IMO we should create new issues for each project type to fix saving of properties by leveraging the API. This issue
about deadlock is indeed fixed and issue #91291 is fixed as well.
Comment 22 Andrei Badea 2007-09-20 17:56:45 UTC
OK, seems it's better to close this. I filed issue 116203 instead and made it block issue 114345.
Comment 23 _ edwingo 2007-09-26 02:47:53 UTC
Created attachment 49532 [details]
Patch to add visualweb/complib as a friend module
Comment 24 _ edwingo 2007-09-26 02:51:02 UTC
Please ignore the attachment to this bug. I accidentally attached it to the wrong one.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo