Bug 113891 - provide ways for implementing interfaces / selecting superclass while creating a new class
provide ways for implementing interfaces / selecting superclass while creatin...
Status: VERIFIED WONTFIX
Product: java
Classification: Unclassified
Component: Project
6.x
All All
: P3 with 1 vote (vote)
: 6.x
Assigned To: Jan Pokorsky
issues@java
:
: 105438 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 19:35 UTC by kawazu428
Modified: 2007-10-18 18:48 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kawazu428 2007-08-27 19:35:25 UTC
By now the "New File" -> "Java Class" wizard just allows for specifying class and package name. Is there a possibility
of enhancing this by allowing users to specify

- which interface the class to be created should implement, and/or
- which superclass it should be derived from,

and make the class skeleton created subsequently automatically provide skeletons for implementing / overriding methods
required to override/implement?
Comment 1 Jan Pokorsky 2007-10-18 14:41:50 UTC
Java wizards were full of such UI fields and lists initially. It was possible to add also fields and methods. The reason
was that the editor lacked features like editor hints, automatic imports, ... Later we have decided to remove all that
stuff since it does not make sense to duplicate editor features in the wizard.

So, in order to add an interface you can use code completion and to implement method(s) use either code completion or
editor hints. There is also the Insert Code feature for constructors, equals() and hash(). It is really simple today.
Comment 2 kawazu428 2007-10-18 14:46:40 UTC
Guess it's a matter of what one is used to, but your explanation sounds logical, thanks for pointing this out. Verifying
this one for the sake of having it closed. :)
Comment 3 Jan Pokorsky 2007-10-18 18:48:49 UTC
*** Issue 105438 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo