Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 113388 - [jdk7 & jdk6u14 & jdk6u15 & jdk6u16] Do not use HTML in tab titles [was: Output mixed up by IOProvider with jdk 7]
[jdk7 & jdk6u14 & jdk6u15 & jdk6u16] Do not use HTML in tab titles [was: Outp...
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Output Window
6.x
All All
: P2 with 1 vote (vote)
: 6.x
Assigned To: t_h
issues@platform
jdk_bug_6670274 67patch2-verified
: RELNOTE
: 110229 123045 123184 153262 164598 164724 167168 169047 170776 170847 171333 171587 178412 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-21 17:10 UTC by mgoe
Modified: 2011-02-28 14:07 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Module suite project showing the issue. (4.76 KB, application/x-gzip)
2007-08-21 17:15 UTC, mgoe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mgoe 2007-08-21 17:10:24 UTC
Using jdk 7 (tested with b16 and b18) there is a problem with output performed via the IOProvider API. If several 
threads try to output some text to a thread specific tab (selected by the name given to 
IOProvider.getDefault().getIO(name, false)) some output is written to a wrong tab. If have implemented a small 
netbeans module suite project showing this issue. Once the main window is open the program starts some tasks named 
Task_nn (with nn being the task number). Each task will print some text as follows:
IOProvider.getDefault().getIO(name, false).getOut().println(name + " " + i);
with name being the task name and i being a counter to simulate the work done in the task.
After all tasks are finished one can see that some tabs exist twice although the task names used to obtain the 
InputOutput were unique. One can also see that for example output written from Task_3 has been written to a tab called 
Task_7 (watch for tabs still written with a bold font). This all happens only with jdk 7. With jdk 6 I didn't observe 
such problems. So I'm not sure if it is a netbeans or a jdk problem. Since everything else runs fine I tend toward 
netbeans. If it is not a netbeans bug I would appreciate if you could hand over the example to your jdk colleagues 
because providing a module suite project via the jdk bug reporting system is a real pain.

Best regards,
Martin Goettlicher
Comment 1 mgoe 2007-08-21 17:15:10 UTC
Created attachment 46988 [details]
Module suite project showing the issue.
Comment 2 Antonin Nebuzelsky 2008-02-07 15:50:52 UTC
Reassigning to new module owner Tomas Holy.
Comment 3 t_h 2008-02-29 14:37:23 UTC
It is JDK 1.7 issue. There is problem in BasicTabbedPaneUI$Handler.updateHtmlViews() - there is
htmlViews.insertElementAt(v, index); instead of htmlViews.setElementAt(v, index); so new view is added (to already
preallocated vector) - this shifts/breaks others.
Comment 4 t_h 2008-02-29 14:40:57 UTC
I used JDK 1.7 b24. I reported JDK  bug.
Comment 5 t_h 2008-02-29 14:44:17 UTC
*** Issue 123184 has been marked as a duplicate of this issue. ***
Comment 6 t_h 2008-02-29 14:46:08 UTC
*** Issue 110229 has been marked as a duplicate of this issue. ***
Comment 7 t_h 2008-02-29 14:51:15 UTC
*** Issue 123045 has been marked as a duplicate of this issue. ***
Comment 8 mgoe 2008-02-29 14:56:31 UTC
Thank you for analyzing this issue. Could you please post the SUN bug id?

Best regards,
Martin Goettlicher
Comment 9 Jesse Glick 2008-02-29 17:15:07 UTC
For issues which are WONTFIX due to a JDK bug, the status whiteboard should contain

jdk_bug_1234567
Comment 11 Tomas Danek 2008-03-20 14:08:59 UTC
reproduced also on openjdk6 
Comment 12 t_h 2008-03-20 16:52:34 UTC
openjdk6 is based on jdk7 so this bug was probably back-ported
Comment 13 _ tboudreau 2009-05-11 16:47:23 UTC
*** Issue 164724 has been marked as a duplicate of this issue. ***
Comment 14 t_h 2009-05-18 08:01:01 UTC
*** Issue 164598 has been marked as a duplicate of this issue. ***
Comment 15 Marian Mirilovic 2009-05-21 16:49:13 UTC
We need to find a workaround for this issue, or/and mention that in release notes.
Comment 16 Antonin Nebuzelsky 2009-05-22 14:23:00 UTC
A workaround will be integrated today. For JDK 6u14 only we will not use the bold font in output subtabs to indicate the
output stream is open, but we will use * instead.

Also, this bug will be mentioned in 6.7 release notes.

I suggest the following release notes text: "When running NetBeans IDE with JDK 6u14 the output tabs cannot use the bold
font to indicate the output stream is open. Due to the bug #6670274 in JDK, the bold font is not used and an asterisk
symbol is used instead."
Comment 17 Marian Mirilovic 2009-05-22 14:47:04 UTC
We need to add notes also into NB 6.5.1 (because of bundle with JDK6u14) .... text :

"When titles in tabs in Output Window are broken and/or show html tags and you are running on JDK 6u14  you are facing
bug in JDK #6670274. If it's possible use another JDK (not JDK 6u14) instead."
Comment 18 t_h 2009-05-22 16:53:32 UTC
core-main #5d5e6fb345ed
Comment 19 Quality Engineering 2009-05-23 06:54:07 UTC
Integrated into 'main-golden', will be available in build *200905230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5d5e6fb345ed
User: Tomas Holy <t_h@netbeans.org>
Log: #113388: Do not use HTML in tab titles with JDK 1.6.0_14
Comment 20 t_h 2009-06-12 16:53:04 UTC
*** Issue 153262 has been marked as a duplicate of this issue. ***
Comment 21 t_h 2009-06-16 17:46:59 UTC
*** Issue 167168 has been marked as a duplicate of this issue. ***
Comment 22 Marian Mirilovic 2009-06-19 07:58:15 UTC
verified in NB 6.7 RC3
Comment 23 Jesse Glick 2009-06-19 15:44:16 UTC
We should perhaps escalate this bug - it's only listed as P3.
Comment 24 Antonin Nebuzelsky 2009-06-19 15:56:06 UTC
Right. It was already escalated to JDK team and they confirmed the fix is targeted into 6u15.
Comment 25 t_h 2009-07-30 11:06:05 UTC
*** Issue 169047 has been marked as a duplicate of this issue. ***
Comment 26 mgoe 2009-08-06 09:14:58 UTC
The workaround for jdk_bug_6670274 which has been added in Netbeans does no longer work with the new jdk6u15 release.
Comment 27 t_h 2009-08-06 09:41:50 UTC
AFAIK 6u15 was not released yet, issue was escalated a should be fixed in 6u15. That is why workaround is enabled just
for 6u14.
Comment 28 mgoe 2009-08-06 09:48:20 UTC
jdk6u15 was released yesterday and I can confirm that html tabs don't work correctly.
Comment 29 t_h 2009-08-06 12:09:15 UTC
You are right, thanks. core-main #83d4d06999ed
Comment 30 Quality Engineering 2009-08-07 05:42:57 UTC
Integrated into 'main-golden', will be available in build *200908070201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/83d4d06999ed
User: Tomas Holy <t_h@netbeans.org>
Log: #113388: [jdk7 & jdk6u14 & jdk6u15] Do not use HTML in tab titles
Comment 31 Antonin Nebuzelsky 2009-08-11 15:30:26 UTC
> It was already escalated to JDK team and they confirmed the fix is targeted into 6u15.

I checked with JDK team and they confirmed the fix was unfortunately not included in 6u15.

The fix of #6670274 is now planned to the currently open 6u18.

We need to extend the workaround on our side. And we need to release the fix to 6.7(.1) on UC.
Comment 32 t_h 2009-08-24 15:12:53 UTC
core-main #060269744e69
http://hg.netbeans.org/release67_fixes/rev/f0d28acb8c50
Comment 33 Quality Engineering 2009-08-25 02:41:00 UTC
Integrated into 'main-golden', will be available in build *200908242212* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/060269744e69
User: Tomas Holy <t_h@netbeans.org>
Log: #113388: Do not use HTML in tab titles for jdk6u14-u17
Comment 34 t_h 2009-08-26 14:56:15 UTC
*** Issue 170776 has been marked as a duplicate of this issue. ***
Comment 35 t_h 2009-08-26 15:18:27 UTC
*** Issue 170847 has been marked as a duplicate of this issue. ***
Comment 36 mgoe 2009-09-03 09:24:25 UTC
A few days ago the first build of jdk6u18 was released. The changes document does not contain the bug 6670274 which is 
causing the issue described in this report. Could someone at SUN please make sure that a fix for this annoying bug is 
added to jdk6u18. It is open now for more than a year.

Martin
Comment 37 Antonin Nebuzelsky 2009-09-03 09:44:45 UTC
Martin, thanks for the follow-up.

The JDK bug #6670274 is currently marked as to be fixed in b02 of 6u18. Could you verify this is the case as soon as b02
is released and confirm here? Thanks for the help!
Comment 38 t_h 2009-09-07 10:47:07 UTC
*** Issue 171333 has been marked as a duplicate of this issue. ***
Comment 39 martin_zmrhal 2009-09-07 17:04:20 UTC
Was able to reproduce with JDK 1.7.0-ea-b65 - for steps to reproduce watch the video here (I recommend to switch to HD)
http://www.youtube.com/watch?v=cRjdL9ytIbA

However running JDK 1.6.0u16 (and the same steps) it works fine - the tabs titles are not bold, but marked with
asterisk. Why not to use the same behavior for JDK 1.7?
Comment 40 t_h 2009-09-08 10:55:50 UTC
The workaround is for final released versions (JDK6u14-17). Final JDK7 release should have this bug fixed.
Comment 41 martin_zmrhal 2009-09-08 11:52:13 UTC
Well, then it is verified... In NB 6.7.1, JDK6u16 + update from UC
Comment 42 mgoe 2009-09-10 08:46:00 UTC
jdk6u18 b02 was released yesterday. It still does not contain a fix for #6670274.

Martin
Comment 43 t_h 2009-09-10 11:48:24 UTC
*** Issue 171333 has been marked as a duplicate of this issue. ***
Comment 44 Antonin Nebuzelsky 2009-09-10 13:38:21 UTC
> jdk6u18 b02 was released yesterday. It still does not contain a fix for #6670274.

I talked to the JDK engineer now and the fix will be in b03, for sure this time. :-/
Comment 45 Antonin Nebuzelsky 2009-10-30 15:30:38 UTC
*** Issue 171587 has been marked as a duplicate of this issue. ***
Comment 46 Antonin Nebuzelsky 2009-10-30 15:32:19 UTC
t_h tested with 6u18 b03 and the fix is in.
Comment 47 t_h 2009-10-30 18:34:45 UTC
*** Issue 175804 has been marked as a duplicate of this issue. ***
Comment 48 t_h 2009-12-10 03:03:52 UTC
*** Bug 178412 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo