Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 113351 - Nb55 platform compat: org.netbeans.modules.options.api moved from ide to platform
Nb55 platform compat: org.netbeans.modules.options.api moved from ide to plat...
Status: RESOLVED DUPLICATE of bug 113341
Product: platform
Classification: Unclassified
Component: Module System
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
:
Depends on:
Blocks: 113340
  Show dependency treegraph
 
Reported: 2007-08-21 14:29 UTC by pzajac
Modified: 2008-12-23 08:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pzajac 2007-08-21 14:29:04 UTC
Module org.netbeans.modules.options.api was moved from cluster IDE to PLATFORM in NetBeans 6.0. It probably causes
incompativility with NetBeans 5.5 platform.
   
   Platform - The module named org.netbeans.modules.options.api/1 was needed and not found.
   Keymap Options - The module named org.netbeans.modules.options.api/1 was needed and not found.
   Core - UI - The module named org.netbeans.modules.options.api/1 was needed and not found.
   Form Editor - The module named org.netbeans.modules.options.api/1 was needed and not found.
   Auto Update UI - The module named org.netbeans.modules.options.api/1 was needed and not found.
   Options Module - Editor - The module named org.netbeans.modules.options.api/1 was needed and not found.
   Ant - The module named org.netbeans.modules.options.api/1 was needed and not found.
Comment 1 Jaroslav Tulach 2007-08-28 09:04:40 UTC
This is the same problem as issue 113341, e.g. the module has been moved to platform and the 5.5.1 version takes 
precedence. The workaround is to delete the module and associated files:

rm ide7/config/Modules/org-netbeans-modules-options-api.xml ide7/modules/org-netbeans-modules-options-api.jar 
ide7/update_tracking/org-netbeans-modules-options-api.xml

*** This issue has been marked as a duplicate of 113341 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo