Bug 11293 - UnsatisfiedLinkError occurs in MouseWheelHandler.initIDs
UnsatisfiedLinkError occurs in MouseWheelHandler.initIDs
Status: CLOSED FIXED
Product: ide
Classification: Unclassified
Component: Code
3.x
PC Windows ME/2000
: P1 (vote)
: TBD
Assigned To: _ rkubacki
:
: 12600 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-11 09:27 UTC by chrisim
Modified: 2003-07-07 13:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chrisim 2001-04-11 09:27:45 UTC
Step :

1. Execute Tools-Update Center...
2. Check the second radio button (Install module (.nbm files) manually 
downloaded.... option)
3. add the wheel.nbm file located in the local directory and finish setting
4. Exit NetBeans IDE 3.2 and restart it.

=> "Unexpected Exception" dialog appears....
Detail contents :
Wed Apr 11 17:26:05 KST 2001: java.lang.UnsatisfiedLinkError: initIDs
java.lang.UnsatisfiedLinkError: initIDs
        at org.netbeans.modules.mousewheel.MouseWheelHandler.initIDs(Native 
Method)
        at org.netbeans.modules.mousewheel.MouseWheelHandler.<clinit>
(MouseWheelHandler.java:49)
        at org.netbeans.modules.mousewheel.MouseWheelModule$1.run
(MouseWheelModule.java:73)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:154)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:337)
        at java.awt.EventDispatchThread.pumpOneEvent
(EventDispatchThread.java:103)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:84)

=============================================================
ide.log file contents :

-------------------------------------------------------------------------------
>Log Session: 2001³â 4¿ù 11ÀÏ ¼ö¿äÀÏ ¿ÀÈÄ 05½Ã00ºÐ30ÃÊ KST
>System Info: 
  Product Version       = NetBeans IDE 3.2, Release Candidate 1 (Build 27)
  IDE Versioning        = IDE/1 spec=1.2.1 impl=27
  Operating System      = Windows 2000 version 5.0 running on x86
  Java; VM; Vendor      = 1.3.1-beta; Java HotSpot(TM) Client VM 1.3.1beta-b15; 
Sun Microsystems Inc.
  Java Home             = d:\devtool\jdk1.3.1\jre
  System Locale         = ko_KR
  Home Dir; Current Dir = C:\Documents and Settings\chrisim; 
D:\DevTool\NetBeans\bin
  IDE Install; User Dir = D:\DevTool\NetBeans; D:\DevTool\NetBeans\bin\usr
  CLASSPATH             = D:\DevTool\NetBeans\lib\patches\openide-
compat.jar;D:\DevTool\NetBeans\lib\openide-
fs.jar;D:\DevTool\NetBeans\lib\openide.jar;D:\DevTool\NetBeans\lib\openide-
util.jar;D:\DevTool\NetBeans\lib\openide-
nodes.jar;D:\DevTool\NetBeans\lib\core.jar;D:\DevTool\NetBeans\lib\ext\jaxp.jar;
D:\DevTool\NetBeans\lib\ext\xerces.jar;D:\DevTool\NetBeans\lib\ext\regexp.jar;D:
\DevTool\NetBeans\lib\ext\sax2.jar;D:\DevTool\NetBeans\lib\ext\parser.jar;D:\Dev
Tool\NetBeans\lib\ext\servlet.jar;D:\DevTool\NetBeans\lib\ext\jh.jar;D:\DevTool\
NetBeans\lib\ext\rmi-
ext.jar;D:\DevTool\NetBeans\lib\ext\jpython.jar;d:\devtool\jdk1.3.1
\lib\dt.jar;d:\devtool\jdk1.3.1\lib\tools.jar
-------------------------------------------------------------------------------
[INFO] Loaded modules: org.netbeans.core/1 (1.0/unspec); 
org.netbeans.modules.autoupdate/1 (1.6.1/27); org.netbeans.modules.clazz/1 
(1.6.1/27); org.netbeans.modules.debugger.core/2 (2.0.1/27); 
org.netbeans.modules.debugger.debug/1 (1.8.1/27); 
org.netbeans.modules.debugger.jpda/1 (1.8.1/27); org.netbeans.modules.editor/1 
(1.7.1/27); org.netbeans.modules.jarpackager/2 (1.6.1/27); 
org.netbeans.modules.java/1 (1.6.1/27); org.netbeans.modules.javadoc/1 
(1.6.1/27); org.netbeans.modules.objectbrowser/1 (1.6.1/27); 
org.netbeans.modules.projects/1 (1.6.1/27); org.netbeans.modules.properties/1 
(1.6.1/27); org.netbeans.modules.i18n/1 (1.7/27); 
org.netbeans.modules.properties.syntax/1 (1.6.1/27); 
org.netbeans.modules.text/1 (1.6.1/27); org.netbeans.modules.usersguide/1 
(1.7.1/27); org.openidex.util/1 (1.7.1/27); org.netbeans.modules.utilities/1 
(1.6.1/27); org.netbeans.modules.apisupport.lite/1 (0.1.1/27); 
org.netbeans.modules.mousewheel/1 (0.0.1/unspec)
java.lang.UnsatisfiedLinkError: no wheel in java.library.path
	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1312)
	at java.lang.Runtime.loadLibrary0(Runtime.java:749)
	at java.lang.System.loadLibrary(System.java:820)
	at org.netbeans.modules.mousewheel.MouseWheelModule.<clinit>
(MouseWheelModule.java:46)
	at java.io.ObjectStreamClass.hasStaticInitializer(Native Method)
	at java.io.ObjectStreamClass.computeSerialVersionUID
(ObjectStreamClass.java:923)
	at java.io.ObjectStreamClass.access$200(ObjectStreamClass.java:46)
	at java.io.ObjectStreamClass$2.run(ObjectStreamClass.java:420)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.io.ObjectStreamClass.init(ObjectStreamClass.java:401)
	at java.io.ObjectStreamClass.lookupInternal
(ObjectStreamClass.java:112)
	at java.io.ObjectStreamClass.setClass(ObjectStreamClass.java:566)
	at java.io.ObjectInputStream.inputClassDescriptor
(ObjectInputStream.java:936)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:366)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:350)
	at java.io.ObjectInputStream.inputClassFields
(ObjectInputStream.java:2263)
	at java.io.ObjectInputStream.defaultReadObject
(ObjectInputStream.java:519)
	at org.openide.util.SharedClassObject$WriteReplace.readObject
(SharedClassObject.java:472)
	at java.lang.reflect.Method.invoke(Native Method)
	at java.io.ObjectInputStream.invokeObjectReader
(ObjectInputStream.java:2214)
	at java.io.ObjectInputStream.inputObject(ObjectInputStream.java:1411)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:386)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:236)
	at org.openide.util.io.NbObjectInputStream.readSafely
(NbObjectInputStream.java:78)
	at org.netbeans.core.ModuleInstaller.deExternalizeModules
(ModuleInstaller.java:992)
	at org.netbeans.core.ModuleInstaller.initialize
(ModuleInstaller.java:244)
	at org.netbeans.core.NonGui.run(NonGui.java:479)
	at org.netbeans.core.Main.run(Main.java:168)
	at org.openide.TopManager.initializeTopManager(TopManager.java:120)
	at org.openide.TopManager.getDefault(TopManager.java:81)
	at org.netbeans.core.Main.main(Main.java:255)
	at org.netbeans.core.TopThreadGroup.run(TopThreadGroup.java:90)
	at java.lang.Thread.run(Thread.java:484)
JavadocModule: numberOfStarts=7
*********** Exception occurred ************
Wed Apr 11 17:00:43 KST 2001: java.lang.UnsatisfiedLinkError: initIDs
java.lang.UnsatisfiedLinkError: initIDs
	at org.netbeans.modules.mousewheel.MouseWheelHandler.initIDs(Native 
Method)
	at org.netbeans.modules.mousewheel.MouseWheelHandler.<clinit>
(MouseWheelHandler.java:49)
	at org.netbeans.modules.mousewheel.MouseWheelModule$1.run
(MouseWheelModule.java:73)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:154)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:337)
[catch] at java.awt.EventDispatchThread.pumpOneEvent
(EventDispatchThread.java:103)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:84)
WARNING: d:\devtool\jdk1.3.1\jre\classes cannot be opened
org.openide.filesystems.FSException: Root d:\devtool\jdk1.3.1\jre\classes does 
not exist.


============================

I hope to have feedback as soon as possible~ ^^*
Have a nice day~~~
Comment 1 Jan Zajicek 2001-04-11 12:33:02 UTC
If I remember, Radim, developed this utility. Assigning.
Comment 2 _ rkubacki 2001-04-12 10:12:06 UTC
Compatibility issue between NB3.1 and 3.2. Please upgrade to newer version from
http://sourceforge.net/projects/nbmousewheel
Comment 3 Jan Zajicek 2001-06-08 09:13:29 UTC
*** Issue 12600 has been marked as a duplicate of this issue. ***
Comment 4 Jan Chalupa 2003-07-07 13:57:38 UTC
Obsolete issue resolved for 3.4 or earlier. Marking as VERIFIED, will CLOSE shortly.
Comment 5 Jan Chalupa 2003-07-07 13:59:49 UTC
Closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo