Bug 11290 - Scanning Ant project can notify expected errors with dialog
Scanning Ant project can notify expected errors with dialog
Status: CLOSED FIXED
Product: projects
Classification: Unclassified
Component: Ant
3.x
PC Linux
: P4 (vote)
: 3.x
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-11 08:03 UTC by Jesse Glick
Modified: 2003-06-30 14:46 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2001-04-11 08:04:00 UTC
If you run an Ant target and afterwards, when it is scanning the project for
newly defined tasks, one of them throws e.g. NoClassDefFoundError while
analyzing its task structure, this will be reported with an error dialog. (The
situation can happen e.g. after running real-clean target on nbbuild/build.xml,
where custom NB tasks are compiled, loaded, run, and then later in execution the
classfiles are deleted--after execution is complete, the project may have some
tasks defined which can no longer be resolved.) Such an error should be handled
the same as errors encountered when scanning built-in tasks at startup: warning
exception printed to log file, as they are harmless.

Fix prepared but not tested in trunk.
Comment 1 Jesse Glick 2001-04-12 12:13:45 UTC
Fixed in the trunk: IntrospectedInfo.java 1.3.
Comment 2 Jesse Glick 2001-04-13 17:42:59 UTC
Fixed in release32.
Comment 3 Jan Chalupa 2001-05-05 19:30:20 UTC
Target milestone -> 3.2
Comment 4 Milan Kubec 2001-06-28 16:37:07 UTC
Verified in build 20010628 by not being able to reproduce it.
Comment 5 Quality Engineering 2003-06-30 14:46:23 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.



By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo