Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 112839 - Output from JSP compiler not shown in output window
Output from JSP compiler not shown in output window
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Ant
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jesse Glick
issues@projects
:
Depends on: 56341 121512
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-15 08:17 UTC by Jiri Skrivanek
Modified: 2007-11-12 18:22 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2007-08-15 08:17:45 UTC
Since build 070814 (#2492) there is missing error message from JSP compiler. It is high priority because it blocks UI
commit validation tests:

http://deadlock.netbeans.org/hudson/job/trunk/2492/testReport/

Probably it is caused by changes related to issue 56341:

http://deadlock.netbeans.org/hudson/job/trunk/2492/changes

To reproduce:

- create web application (tested with Glassfish server)
- add some non-compilable code into index.jsp (e.g. <%= nonExistentVar %>)
- compile index.jsp (F9)
- the message in the output window should be

Compiling 1 source file to D:\Development\builds\nbUserdir\WebApplication2\build\generated\classes
D:\Development\builds\nbUserdir\WebApplication2\build\generated\src\org\apache\jsp\a_jsp.java:52: cannot find symbol
symbol  : variable nonExistentVar
location: class org.apache.jsp.a_jsp
      out.print( nonExistentVar );
                 ^
1 error
D:\Development\builds\nbUserdir\WebApplication2\nbproject\build-impl.xml:447: The following error occurred while
executing this line:
D:\Development\builds\nbUserdir\WebApplication2\nbproject\build-impl.xml:439: The following error occurred while
executing this line:
D:\Development\builds\nbUserdir\WebApplication2\nbproject\build-impl.xml:176: Compile failed; see the compiler error
output for details.
BUILD FAILED (total time: 1 second)

but it is only 

Compiling 1 source file to D:\Development\builds\nbUserdir-20070815085713\WebApplication1\build\generated\classes
D:\Development\builds\nbUserdir-20070815085713\WebApplication1\nbproject\build-impl.xml:447: The following error
occurred while executing this line:
D:\Development\builds\nbUserdir-20070815085713\WebApplication1\nbproject\build-impl.xml:439: The following error
occurred while executing this line:
D:\Development\builds\nbUserdir-20070815085713\WebApplication1\nbproject\build-impl.xml:176: Compile failed; see the
compiler error output for details.
BUILD FAILED (total time: 0 seconds)
Comment 1 Jesse Glick 2007-08-15 14:54:21 UTC
Will look at it.
Comment 2 Jesse Glick 2007-08-15 15:54:40 UTC
Fixed for now by reverting entry hook of issue #56341. Mysterious, though. The problem is in <javac>, not <java> which
is what #56341 is supposed to be affecting; does not affect regular sources in the same project; and disappears if
fork="true" is used (e.g. if you use a particular JDK). Will investigate and try to fix better.

Checking in ant/src-bridge/org/apache/tools/ant/module/bridge/impl/BridgeImpl.java;
/shared/data/ccvs/repository/ant/src-bridge/org/apache/tools/ant/module/bridge/impl/BridgeImpl.java,v  <--  BridgeImpl.java
new revision: 1.45; previous revision: 1.44
done
Comment 3 Jesse Glick 2007-08-15 17:59:46 UTC
Found it, was a stream closing issue.
Comment 4 Jiri Skrivanek 2007-08-16 08:11:53 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo