Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 112766 - StockQuoteService sample opens with exceptions
StockQuoteService sample opens with exceptions
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Identity
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Peter Liu
issues@serverplugins
: REGRESSION
Depends on:
Blocks: 112237
  Show dependency treegraph
 
Reported: 2007-08-14 16:24 UTC by Jaroslav Pospisil
Modified: 2007-10-31 16:46 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (61.40 KB, text/plain)
2007-08-24 16:46 UTC, Jaroslav Pospisil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Pospisil 2007-08-14 16:25:01 UTC
Build200708130000,JDK1.6.0_02.Vista Bussiness

Open in IDE StockService or StockClient Identity Blueprints samples - there're server problems icons,even if Glassfish
v2 installed by default.You have to Resolve Server Problems in order to fix this.
Comment 1 Jaroslav Pospisil 2007-08-14 18:25:51 UTC
I meant reference problems,not server.
Comment 2 Peter Liu 2007-08-14 21:21:08 UTC
I believe this is because the sample project is originally created to use an appserver instance with a different name.
Comment 3 Peter Liu 2007-08-16 01:30:39 UTC
Just checked in a fix for this into NB 6 trunk. There is no more missing reference problem.

Comment 4 Jaroslav Pospisil 2007-08-24 16:45:29 UTC
References are fixed,but now both samples opens with exception:

java.lang.AssertionError: Missing file null
	at org.netbeans.api.project.ant.AntBuildExtender.readProjectMetadata(AntBuildExtender.java:212)
	at org.netbeans.api.project.ant.AntBuildExtender.getExtensions(AntBuildExtender.java:149)
	at org.netbeans.api.project.ant.AntBuildExtenderAccessorImpl.getExtensions(AntBuildExtenderAccessorImpl.java:50)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper.applyBuildExtensions(GeneratedFilesHelper.java:417)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper.access$400(GeneratedFilesHelper.java:74)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper$1$1.run(GeneratedFilesHelper.java:288)
	at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:98)
	at org.openide.filesystems.FileSystem.runAtomicAction(FileSystem.java:477)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper$1.run(GeneratedFilesHelper.java:257)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper$1.run(GeneratedFilesHelper.java:251)
	at org.openide.util.Mutex.writeAccess(Mutex.java:357)
	at
org.netbeans.spi.project.support.ant.GeneratedFilesHelper.generateBuildScriptFromStylesheet(GeneratedFilesHelper.java:250)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper$3.run(GeneratedFilesHelper.java:757)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper$3.run(GeneratedFilesHelper.java:754)
	at org.openide.util.Mutex.writeAccess(Mutex.java:357)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper.refreshBuildScript(GeneratedFilesHelper.java:753)
	at org.netbeans.modules.web.project.WebProject$ProjectOpenedHookImpl.projectOpened(WebProject.java:732)
	at org.netbeans.spi.project.ui.ProjectOpenedHook$1.projectOpened(ProjectOpenedHook.java:59)
	at org.netbeans.spi.project.ui.support.UILookupMergerSupport$OpenHookImpl.projectOpened(UILookupMergerSupport.java:163)
	at org.netbeans.spi.project.ui.ProjectOpenedHook$1.projectOpened(ProjectOpenedHook.java:59)
	at org.netbeans.modules.project.ui.OpenProjectList.notifyOpened(OpenProjectList.java:646)
	at org.netbeans.modules.project.ui.OpenProjectList.doOpenProject(OpenProjectList.java:689)
	at org.netbeans.modules.project.ui.OpenProjectList.doOpen(OpenProjectList.java:337)
	at org.netbeans.modules.project.ui.OpenProjectList.access$100(OpenProjectList.java:87)
	at org.netbeans.modules.project.ui.OpenProjectList$3.run(OpenProjectList.java:237)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:539)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:964)

Attaching messages.log
Comment 5 Jaroslav Pospisil 2007-08-24 16:46:31 UTC
Created attachment 47337 [details]
messages.log
Comment 6 Peter Liu 2007-08-27 22:33:00 UTC
I believe this is a bug introduced to the web project recently. I've seen it happen with a newly created project. 
However, I think this issue has already been fixed using a later build.  I am closing this as worksforme and please
verify with a later build.

Comment 7 Milan Kuchtiak 2007-08-28 09:30:23 UTC
Sorry for reopaning, I can reproduce the issue on the latest build 08/28.

Environment 

Linux
jdk1.5
GlassFish build 55 with AM installed

I got exactly the same stack trace.
Comment 8 Peter Liu 2007-08-29 22:46:58 UTC
It turns out the project.properties for the client sample contains references to the jsr311 library which is only
available on the update center. I removed it and the project opens fine.  BTW, I wasn't able to reproduce the problem
for the Stock Service sample.  I've tested this with the latest NB build. Hopefully, this is issue is completely resolved.

 
Comment 9 Jaroslav Pospisil 2007-09-03 13:23:54 UTC
Still reproducible in build 200709030000 for both samples.StockService throws only exception,but StockClient throws one
more exception and then hangs up IDE (cursor set to working,but I waited 10 minutes and nothing happened.
Second exception:

java.lang.IllegalArgumentException: Project StockQuoteClient is not open and cannot be set as main.
	at org.netbeans.modules.project.ui.OpenProjectList.setMainProject(OpenProjectList.java:480)
	at org.netbeans.modules.project.ui.actions.NewProject$2.run(NewProject.java:190)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
[catch] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
Comment 10 Peter Liu 2007-09-04 21:48:00 UTC
Hi Jarda,

We need your approval to get this issue fixed for beta1. In our opinion, this is a stopper because users cannot create
the sample application for identity.

Thanks.
Comment 11 Peter Liu 2007-09-05 02:48:07 UTC
From my one beta1 build, I wasn't able to reproduce the problem.  Do you see any other error message in the log file?

I'll try downloading the actual beta1 bits and try it again tomorrow.

Comment 12 Jaroslav Pospisil 2007-09-05 10:01:34 UTC
I agree,in beta1 build 200709041200 this seems to be already fixed.Verifiing.
Comment 13 Jaroslav Pospisil 2007-09-06 12:42:03 UTC
Reopening,since still reproducible in trunk builds. In Beta1 it seems fixed,but I don't see how there could be any
fix,which isn't in trunk and is in beta1,since fixing process works in opposite direction.This must be fixed in both
branches,before we could consider it done.
Comment 14 Peter Liu 2007-09-06 19:07:48 UTC
Since this problem no longer exist in beta1, should we move the target milestone to beta2? I just want to make sure this
bugs moves off of the dashboard.

Comment 15 Jaroslav Pospisil 2007-09-07 08:48:33 UTC
I agree,changing the milestone.
Comment 16 Jaroslav Pospisil 2007-09-10 16:50:00 UTC
Hudson trunk build #3145 still contains this issue. In case of StockQuoteService exception doesn't prevent building and
depolying the sample,however StockQuoteClient after both exceptions mentioned upper makes IDE stucks in endless try to
open the sample and it has to bereopen in order to end this.After reopening of IDE, StockQuoteClient sample isn't still
opened. This happens even if first sample is successfully deployed and server running. From this reason I'm raising
priority to P1. 
Comment 17 Jaroslav Pospisil 2007-09-10 17:06:37 UTC
So I've found thanks to jungi,that reason, for what I'm unable to reproduce this issue in Beta 1 is,that in beta's
there's disabled displaying of AssertionExceptions . If I remove "-J -ea" in netbeans.conf in trunk build,result is the
same as in Beta1 build and I can't reproduce it anymore. Decreasing priority again.
Comment 18 Peter Liu 2007-09-21 21:43:02 UTC
I just tried it with the latest trunk build with the -J -ea option and I couldn't reproduce the problem.  Both the
server and client projects are created and built successfully. Changing the resolution to worksforme.

Comment 19 Jaroslav Pospisil 2007-09-24 13:05:14 UTC
Just reproduced with hudson build 3469 (20070924075740). Exceptions are displayed with missing files names this time,
problem however remains the same.The hang-up during StoctQuoteClient opening is very annoying.

java.lang.AssertionError: Missing file jaxws-build.xml for extension jaxws
	at org.netbeans.api.project.ant.AntBuildExtender.readProjectMetadata(AntBuildExtender.java:212)
	at org.netbeans.api.project.ant.AntBuildExtender.getExtensions(AntBuildExtender.java:149)
	at org.netbeans.api.project.ant.AntBuildExtenderAccessorImpl.getExtensions(AntBuildExtenderAccessorImpl.java:50)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper.applyBuildExtensions(GeneratedFilesHelper.java:417)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper.access$400(GeneratedFilesHelper.java:74)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper$1$1.run(GeneratedFilesHelper.java:288)
	at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:98)
	at org.openide.filesystems.FileSystem.runAtomicAction(FileSystem.java:477)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper$1.run(GeneratedFilesHelper.java:257)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper$1.run(GeneratedFilesHelper.java:251)
	at org.openide.util.Mutex.writeAccess(Mutex.java:357)
	at
org.netbeans.spi.project.support.ant.GeneratedFilesHelper.generateBuildScriptFromStylesheet(GeneratedFilesHelper.java:250)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper$3.run(GeneratedFilesHelper.java:757)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper$3.run(GeneratedFilesHelper.java:754)
	at org.openide.util.Mutex.writeAccess(Mutex.java:357)
	at org.netbeans.spi.project.support.ant.GeneratedFilesHelper.refreshBuildScript(GeneratedFilesHelper.java:753)
	at org.netbeans.modules.web.project.WebProject$ProjectOpenedHookImpl.projectOpened(WebProject.java:737)
	at org.netbeans.spi.project.ui.ProjectOpenedHook$1.projectOpened(ProjectOpenedHook.java:59)
	at org.netbeans.spi.project.ui.support.UILookupMergerSupport$OpenHookImpl.projectOpened(UILookupMergerSupport.java:171)
	at org.netbeans.spi.project.ui.ProjectOpenedHook$1.projectOpened(ProjectOpenedHook.java:59)
	at org.netbeans.modules.project.ui.OpenProjectList.notifyOpened(OpenProjectList.java:650)
	at org.netbeans.modules.project.ui.OpenProjectList.doOpenProject(OpenProjectList.java:695)
	at org.netbeans.modules.project.ui.OpenProjectList.doOpen(OpenProjectList.java:339)
	at org.netbeans.modules.project.ui.OpenProjectList.access$100(OpenProjectList.java:88)
	at org.netbeans.modules.project.ui.OpenProjectList$3.run(OpenProjectList.java:239)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:539)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:964)

java.lang.IllegalArgumentException: Project StockQuoteClient is not open and cannot be set as main.
	at org.netbeans.modules.project.ui.OpenProjectList.setMainProject(OpenProjectList.java:482)
[catch] at org.netbeans.modules.project.ui.actions.NewProject$2.run(NewProject.java:190)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
Comment 20 Peter Liu 2007-09-25 01:40:23 UTC
I added the jaxws-build.xml back into the sample to avoid the assertion error. The fix is checked into trunk.
Comment 21 Jaroslav Pospisil 2007-09-25 17:00:54 UTC
VERIFIED in build 20070925142838
Comment 22 Jaroslav Pospisil 2007-10-18 09:31:44 UTC
Reproducible again in Beta 2 and trunk (Hudson 4022). I got AssertionError and StockQuoteService-war isn't opened.
AssertionError same as the latest one here - most probably caused by removing jaxws-build.xml . I suggest to fix it same
way,as in previous case.
Comment 23 Jaroslav Pospisil 2007-10-18 09:34:40 UTC
Compiling 2 source files to
C:\Users\jp154641\Documents\NetBeansProjects\StockQuoteService4\StockQuoteService4\StockQuoteService-war\build\web\WEB-INF\classes
C:\Users\jp154641\Documents\NetBeansProjects\StockQuoteService4\StockQuoteService4\StockQuoteService-war\src\java\com\samples\StockService.java:45:
package com.sun.stockquote does not exist
import com.sun.stockquote.PriceType;
C:\Users\jp154641\Documents\NetBeansProjects\StockQuoteService4\StockQuoteService4\StockQuoteService-war\src\java\com\samples\StockService.java:46:
package com.sun.stockquote does not exist
import com.sun.stockquote.QuoteResponseType;
C:\Users\jp154641\Documents\NetBeansProjects\StockQuoteService4\StockQuoteService4\StockQuoteService-war\src\java\com\samples\StockService.java:59:
package com.sun.stockquote does not exist
public class StockService implements com.sun.stockquote.StockQuotePortType {
C:\Users\jp154641\Documents\NetBeansProjects\StockQuoteService4\StockQuoteService4\StockQuoteService-war\src\java\com\samples\StockService.java:69:
package com.sun.stockquote does not exist
    public com.sun.stockquote.QuoteResponseType getStockQuote(com.sun.stockquote.QuoteRequestType body) {
C:\Users\jp154641\Documents\NetBeansProjects\StockQuoteService4\StockQuoteService4\StockQuoteService-war\src\java\com\samples\StockService.java:69:
package com.sun.stockquote does not exist
    public com.sun.stockquote.QuoteResponseType getStockQuote(com.sun.stockquote.QuoteRequestType body) {
C:\Users\jp154641\Documents\NetBeansProjects\StockQuoteService4\StockQuoteService4\StockQuoteService-war\src\java\com\samples\StockService.java:70:
cannot find symbol
symbol  : class QuoteResponseType
location: class com.samples.StockService
        QuoteResponseType retVal = new QuoteResponseType();
C:\Users\jp154641\Documents\NetBeansProjects\StockQuoteService4\StockQuoteService4\StockQuoteService-war\src\java\com\samples\StockService.java:70:
cannot find symbol
symbol  : class QuoteResponseType
location: class com.samples.StockService
        QuoteResponseType retVal = new QuoteResponseType();
C:\Users\jp154641\Documents\NetBeansProjects\StockQuoteService4\StockQuoteService4\StockQuoteService-war\src\java\com\samples\StockService.java:83:
cannot find symbol
symbol  : class PriceType
location: class com.samples.StockService
            PriceType priceType = new PriceType();
C:\Users\jp154641\Documents\NetBeansProjects\StockQuoteService4\StockQuoteService4\StockQuoteService-war\src\java\com\samples\StockService.java:83:
cannot find symbol
symbol  : class PriceType
location: class com.samples.StockService
            PriceType priceType = new PriceType();
Note:
C:\Users\jp154641\Documents\NetBeansProjects\StockQuoteService4\StockQuoteService4\StockQuoteService-war\src\java\com\samples\LogHandler.java
uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
9 errors
C:\Users\jp154641\Documents\NetBeansProjects\StockQuoteService4\StockQuoteService4\StockQuoteService-war\nbproject\build-impl.xml:364:
The following error occurred while executing this line:
C:\Users\jp154641\Documents\NetBeansProjects\StockQuoteService4\StockQuoteService4\StockQuoteService-war\nbproject\build-impl.xml:162:
Compile failed; see the compiler error output for details.
BUILD FAILED (total time: 1 second)
Comment 24 Jaroslav Pospisil 2007-10-18 09:54:44 UTC
Mentioned Beta2 build is the one from 17.10.2007 (09-44-20).
Comment 25 Jaroslav Pospisil 2007-10-18 10:46:18 UTC
So this issue seems to be restricted on Trunk builds and Beta2 200710170700 zip. Otherwise there's only issue 119105.
Comment 26 Peter Liu 2007-10-26 21:35:41 UTC
The identity samples have been completely recreated from scratch. Closing this issue as fix. Please verify.
Comment 27 Jaroslav Pospisil 2007-10-31 16:46:21 UTC
V.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo