Bug 11275 - runide.exe hangs at "Initializing CVS Command-Line Client Support..."
runide.exe hangs at "Initializing CVS Command-Line Client Support..."
Status: CLOSED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
3.x
PC Windows ME/2000
: P1 (vote)
: 3.x
Assigned To: Jan Pokorsky
issues@projects
:
: 11238 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-10 20:19 UTC by pollock
Modified: 2003-07-01 14:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
command output from runide.exe (4.12 KB, text/plain)
2001-07-20 20:43 UTC, pollock
Details
Full Thread Dump (7.40 KB, text/plain)
2001-07-20 20:43 UTC, pollock
Details
ZIP file of user's system directory (70.63 KB, application/octet-stream)
2001-07-20 20:43 UTC, pollock
Details
Thread dump of when IDE refuses to exit (10.87 KB, text/plain)
2001-07-20 20:43 UTC, pollock
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pollock 2001-04-10 20:19:22 UTC
runide.exe hangs at "Initializing CVS Command-Line Client Support...".  The 
following exception is generated.  The attached file contains the output from 
runide.  I've reformatted the list of modules to make them easier to read.

I was able to start the IDE once.  I used it for a while, 3-4 hours and 
attempted to shut down.  It would not shut down, so I had to terminate the 
process.  Before shutting down, I did save the project and close all of the 
windows, except for the main/top window.  The next day, I tried to start it, 
and got this error.

I do have cygwin installed, although I haven't tried to use CVS from within 
NetBeans.

java.lang.ClassCastException: org.openide.loaders.DefaultDataObject
        at org.netbeans.modules.projects.PSupport.projectDesktop
(PSupport.java:134)
        at org.netbeans.core.NbProjectOperation.setProject
(NbProjectOperation.java:122)
        at org.netbeans.core.NbProjectOperation.openOrCreateProject
(NbProjectOperation.java:184)
        at org.netbeans.core.NonGui.run(NonGui.java:490)
        at org.netbeans.core.Main.run(Main.java:168)
        at org.openide.TopManager.initializeTopManager(TopManager.java:120)
        at org.openide.TopManager.getDefault(TopManager.java:81)
        at org.netbeans.core.Main.main(Main.java:255)
        at org.netbeans.core.TopThreadGroup.run(TopThreadGroup.java:90)
        at java.lang.Thread.run(Thread.java:484)
Comment 1 pollock 2001-04-10 20:20:38 UTC
Created attachment 1071 [details]
command output from runide.exe
Comment 2 Martin Entlicher 2001-04-10 20:34:25 UTC
Please, can you attach a thread dump after the IDE hangs ?
You can get the thread dump via CTRL-\ in the console from which the IDE is
running.
From the exception it seems, that the bug is in projects, but a full thread dump
will be very valuable to locate where is the problem.
Comment 3 pollock 2001-04-10 20:41:54 UTC
Created attachment 1072 [details]
Full Thread Dump
Comment 4 Jan Pokorsky 2001-04-11 10:32:56 UTC
We cannot reproduce the bug yet. To fix it we need more info. Could you please 
zip and attach the system folder from your user directory? Thanks for your help.
Comment 5 pollock 2001-04-11 14:37:10 UTC
Created attachment 1080 [details]
ZIP file of user's system directory
Comment 6 pollock 2001-04-11 14:39:10 UTC
I have since uninstalled and re-installed 3.2 RC1 into a different directory.  
The exact same problem happens and I can never get past the initial splash 
screen.
Comment 7 Jan Pokorsky 2001-04-11 17:08:29 UTC
*** Issue 11238 has been marked as a duplicate of this issue. ***
Comment 8 Jan Pokorsky 2001-04-11 18:37:34 UTC
Fixed in main [trunk]. Waiting for any objection from nbdev@netbeans.org to 
commit to [release32].

The problem was caused by missing project folder (Projects/NewProject) which was 
 last saved. Now default project is used or created.

Trying to reinstall netbeans to other directory does not solve anything. Your 
settings are saved in a directory which you choose during first instalation and 
netbeans always uses it. Try to use option -userdir <path> (see runide -help) or 
 new dev build or new RC.

Thanks for your interest. If you have some other questions do not hesitate to 
ask.
Comment 9 pollock 2001-04-11 21:03:33 UTC
I believe this may have been caused by the IDE refusing to exit and therefore 
write out what the last project was after I renamed it.

I can recreate the IDE refusing to exit problem, by performing the following 
steps:

1) remove all files in my -userdir directory.
2) runide (will create new files in -userdir directory.
3) select finish and do not import any settings.
4) select finish for initial setup.
5) click close on the tip that comes up.
6) after IDE starts, select exit.  (IDE shutsdown successfully).
7) runide (will simply open the IDE).
8) click close on the tip that comes up.
9) select exit. (IDE does not finish.  Says, "Debugger Finished" in status bar, 
but stays active.


I will attach a thread dump for the state after #9.
Comment 10 pollock 2001-04-11 21:04:38 UTC
Created attachment 1092 [details]
Thread dump of when IDE refuses to exit
Comment 11 David Strupl 2001-04-12 09:10:24 UTC
Thanks for the thread dump. It is very useful. I have created new report
http://www.netbeans.org/issues/show_bug.cgi?id=11338
to deal with the exit problem. After Jan's changes the ide should start
even after killing it from the console. So after this bug (11275) is fixed the ide
should start with corrupted projects dir.
Comment 12 Jan Pokorsky 2001-04-12 12:31:37 UTC
Fixed in [release32].
Comment 13 Jan Chalupa 2001-05-06 14:27:09 UTC
Target milestone -> 3.2
Comment 14 Milan Kubec 2002-10-18 11:30:39 UTC
Verified, not reproducible.
Comment 15 Quality Engineering 2003-07-01 14:16:41 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo