Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 112571 - support for CPPUnit or CUnit
support for CPPUnit or CUnit
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
5.x
All All
: P2 with 12 votes (vote)
: 6.x
Assigned To: nnnnnk
issues@cnd
http://wiki.netbeans.org/CND69UnitTests
:
: 178883 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-10 20:18 UTC by joel_bushart
Modified: 2010-03-29 14:52 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description joel_bushart 2007-08-10 20:18:59 UTC
I would find support for cppunit or cunit similar to that provided for junit very useful.
Comment 1 Vladimir Voskresensky 2007-08-11 07:23:51 UTC
cnd is correct component
Comment 2 Leonid Lenyashin 2009-03-14 20:41:41 UTC
Many user votes for this issue. Also this enhancement has a potential for Cloud Computing. Raising priority. Please
consider this for 6.7.
Comment 3 hashimsaleem 2009-06-24 06:23:09 UTC
Please consider it asap. Thanks.
Comment 5 Alexander Simon 2009-06-27 06:34:59 UTC
I would like to propose the following user view:
- User download, build and install CppUnit.
- IDE has sample CppUnit testing project.
- User create new CppUnit testing project.
- User add needed testing functionality into the testing project.
- User build and run testing project.
- No UI at running testing project, only console output.
- Netbeans has tutorial how to use CppUnit (download, build, install, create project and run tests).

Is it good enough for supporting CppUnit?
If it is good enough the feature can be implemented in NB 6.8.
Comment 6 japsmits 2009-06-29 08:22:09 UTC
That would definitely be a nice start! Nifty features like clicking on an output-line and jumping to the spot where a
test failed would be nice, of course, but not absolutely necessary. Same goes for "automatic" test-generation (i.e. make
an empty test-method for each class-method, like it used to be (or still is) for JUnit). If this functionality is
requested, it could be on the wish-list for a later release.
Comment 7 Alexander Simon 2009-12-20 02:39:28 UTC
NB6.9 plans: http://wiki.netbeans.org/CND69UnitTests
Comment 8 Alexander Simon 2009-12-20 02:39:49 UTC
*** Bug 178883 has been marked as a duplicate of this bug. ***
Comment 9 Quality Engineering 2010-02-04 22:27:52 UTC
Integrated into 'main-golden', will be available in build *201002050200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/b0360deeb9e8
User: Thomas Preisler <thp@netbeans.org>
Log: #112571 support for CPPUnit or CUnit (prototype)
Comment 10 Quality Engineering 2010-02-05 22:49:08 UTC
Integrated into 'main-golden', will be available in build *201002060200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/7abfd5143317
User: Thomas Preisler <thp@netbeans.org>
Log: #112571 support for CPPUnit or CUnit
Prototype: changed tests to be non project files (for now)
Comment 11 Quality Engineering 2010-02-06 21:42:28 UTC
Integrated into 'main-golden', will be available in build *201002070200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0b4eba6c25fc
User: Thomas Preisler <thp@netbeans.org>
Log: #112571 support for CPPUnit or CUnit
Prototype: working on unmanaged projects
Comment 12 Quality Engineering 2010-02-10 02:17:43 UTC
Integrated into 'main-golden', will be available in build *201002100200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/eaedd5b89b11
User: Thomas Preisler <thp@netbeans.org>
Log: #112571 support for CPPUnit or CUnit
Prototype: working on unmanaged projects
Comment 13 Quality Engineering 2010-02-10 21:21:51 UTC
Integrated into 'main-golden', will be available in build *201002110200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/3677e5b6af5b
User: Thomas Preisler <thp@netbeans.org>
Log: #112571 support for CPPUnit or CUnit
Prototype: action cleanup
Comment 14 Quality Engineering 2010-02-11 21:18:21 UTC
Integrated into 'main-golden', will be available in build *201002120200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d3af06a2faf4
User: Thomas Preisler <thp@netbeans.org>
Log: #112571 support for CPPUnit or CUnit
Prototype: test templates
Comment 15 Quality Engineering 2010-02-17 21:55:49 UTC
Integrated into 'main-golden', will be available in build *201002180200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/f1872c5172f1
User: Thomas Preisler <thp@netbeans.org>
Log: #112571 support for CPPUnit or CUnit
Added Debug action to binaries....
Comment 16 Quality Engineering 2010-02-23 22:06:12 UTC
Integrated into 'main-golden', will be available in build *201002240200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/2c3a7d5e3f30
User: Thomas Preisler <thp@netbeans.org>
Log: #112571 support for CPPUnit or CUnit
using -compress
Comment 17 nnnnnk 2010-03-29 14:52:46 UTC
fixed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo