Bug 111947 - indentation completely unusable
indentation completely unusable
Status: RESOLVED DUPLICATE of bug 110102
Product: javascript
Classification: Unclassified
Component: Editor
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jan Jancura
issues@javascript
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 19:39 UTC by Pavel Buzek
Modified: 2009-02-27 14:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Buzek 2007-08-03 19:39:49 UTC
Every line is indented, regardless of its content. Each additional line gets indented more then the previous line. I.e.
the first line by 8 characters from the text above, next by 16, next by 24. JavaScript indentation uses 8 characters
unlike all other editors which use 4 -- I have 4 in Options | Editor | Indentation | Number of Spaces per Indent.

The code looks like this:
function foo () {
        x = 45;
                y = 1;
                                foo();
                                                                bar();
                            
Both in .js and embedded in .html. Build   070719 (I will verify in a newer build shortly).
                                                                                                 
I am filing this as a P1 because this makes the editor completely unusable for typing (maybe you can use it for reading
code).

I could not find a duplicate but I cannot believe that nobody noticed this. If this is a duplicate please make sure the
other bug has appropriate priority.
Comment 1 Martin Schovanek 2007-08-06 10:27:50 UTC
Looks like duplicate of Issue #110102. Feel free to reopen it if you can reproduce in latest build.

*** This issue has been marked as a duplicate of 110102 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo