Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 111875 - REGRESSION: Opening TravelReservationService.bpel takes more than 10 min on MacOS/UNIX
REGRESSION: Opening TravelReservationService.bpel takes more than 10 min on M...
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL
6.x
PC Mac OS X
: P1 (vote)
: TBD
Assigned To: Vladimir Yaroslavskiy
issues@soa
:
: 111878 (view as bug list)
Depends on: 98212
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 11:25 UTC by Andrei Chistiakov
Modified: 2007-08-28 12:57 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Chistiakov 2007-08-03 11:25:49 UTC
Reproduced in build 200708021200 on Mac OS X Intel with JDK 1.5.0_07.

This is a regression since M10.

To reproduce the bug:
- create TRS Sample projects;
- open TravelReservationService.bpel in editor. The opening takes more then 10 minutes. After that IDE preforms very
slow and becomes unusable.
Comment 1 Sergey Lunegov 2007-08-03 11:32:32 UTC
Alexey, please look at this.
Comment 2 Alexey Yarmolenko 2007-08-09 10:02:07 UTC
Vladimir, please take a look on this. I see this exception to appear repeatedly in IDE log when after i click on PL element.

ava.io.IOException: Server returned HTTP response code: 504 for URL: ftp://basename/./xcatalog
   at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1152)
   at sun.net.www.protocol.ftp.FtpURLConnection.getInputStream(FtpURLConnection.java:356)
   at java.net.URL.openStream(URL.java:1007)
   at org.apache.xml.resolver.Catalog.parseCatalogFile(Catalog.java:875)
   at org.apache.xml.resolver.Catalog.parsePendingCatalogs(Catalog.java:779)
   at org.apache.xml.resolver.Catalog.parseCatalog(Catalog.java:627)
   at org.apache.xml.resolver.Catalog.loadSystemCatalogs(Catalog.java:602)
   at org.apache.xml.resolver.CatalogManager.getPrivateCatalog(CatalogManager.java:727)
   at org.apache.xml.resolver.CatalogManager.getCatalog(CatalogManager.java:754)
   at org.apache.xml.resolver.tools.CatalogResolver.initializeCatalogs(CatalogResolver.java:124)
   at org.apache.xml.resolver.tools.CatalogResolver.<init>(CatalogResolver.java:119)
   at org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.resolveUsingApacheCatalog(CatalogModelImpl.java:440)
   at org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.resolveUsingApacheCatalog(CatalogModelImpl.java:420)
   at org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.resolveUsingPublicCatalog(CatalogModelImpl.java:364)
   at org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.resolveUsingCatalog(CatalogModelImpl.java:312)
   at org.netbeans.modules.xml.retriever.catalog.impl.CatalogModelImpl.getModelSource(CatalogModelImpl.java:139)
   at org.netbeans.modules.bpel.model.api.support.ImportHelper.getWsdlModel(ImportHelper.java:85)
   at org.netbeans.modules.bpel.model.api.support.ImportHelper.getWsdlModel(ImportHelper.java:118)
   at org.netbeans.modules.bpel.model.api.support.ImportHelper.getWsdlModel(ImportHelper.java:109)
   at
org.netbeans.modules.bpel.model.impl.references.ExternalModelRetrieverImpl.collectWsdlModelsViaImports(ExternalModelRetrieverImpl.java:117)
   at
org.netbeans.modules.bpel.model.impl.references.ExternalModelRetrieverImpl.getWSDLModels(ExternalModelRetrieverImpl.java:60)
   at org.netbeans.modules.bpel.model.impl.references.WSDLReferenceBuilder.getModels(WSDLReferenceBuilder.java:185)
   at org.netbeans.modules.bpel.model.impl.references.WSDLReferenceBuilder.getWSDLModels(WSDLReferenceBuilder.java:178)
   at org.netbeans.modules.bpel.model.impl.references.WSDLReferenceBuilder.getWSDLModels(WSDLReferenceBuilder.java:167)
   at org.netbeans.modules.bpel.model.impl.references.PartnerLinkTypeResolver.resolve(WSDLReferenceBuilder.java:629)
   at org.netbeans.modules.bpel.model.impl.references.GlobalWSDLReferenceImpl.get(GlobalWSDLReferenceImpl.java:58)
   at org.netbeans.modules.bpel.model.impl.references.GlobalWSDLReferenceImpl.get(GlobalWSDLReferenceImpl.java:34)
   at org.netbeans.modules.bpel.model.impl.references.RoleResolver.resolve(WSDLReferenceBuilder.java:751)
   at org.netbeans.modules.bpel.model.impl.references.WSDLReferenceImpl.get(WSDLReferenceImpl.java:53)
   at org.netbeans.modules.bpel.model.impl.references.WSDLReferenceImpl.get(WSDLReferenceImpl.java:36)
   at org.netbeans.modules.bpel.properties.props.editors.ModelReferenceEditor.getValue(ModelReferenceEditor.java:69)
   at org.openide.explorer.propertysheet.PropUtils.updateEdFromProp(PropUtils.java:863)
   at org.openide.explorer.propertysheet.PropUtils.getPropertyEditor(PropUtils.java:826)
   at org.openide.explorer.propertysheet.ReusablePropertyModel.getPropertyEditor(ReusablePropertyModel.java:79)
   at org.openide.explorer.propertysheet.RendererFactory.preparePropertyEditor(RendererFactory.java:237)
   at org.openide.explorer.propertysheet.RendererFactory.getRenderer(RendererFactory.java:145)
   at org.openide.explorer.propertysheet.SheetCellRenderer.getTableCellRendererComponent(SheetCellRenderer.java:129)
   at org.openide.explorer.propertysheet.BaseTable.prepareRenderer(BaseTable.java:586)
   at org.openide.explorer.propertysheet.SheetTable.prepareRenderer(SheetTable.java:515)
   at javax.swing.plaf.basic.BasicTableUI.paintCell(BasicTableUI.java:2070)
   at javax.swing.plaf.basic.BasicTableUI.paintCells(BasicTableUI.java:1972)
   at javax.swing.plaf.basic.BasicTableUI.paint(BasicTableUI.java:1895)
   at javax.swing.plaf.ComponentUI.update(ComponentUI.java:154)
   at javax.swing.JComponent.paintComponent(JComponent.java:742)
   at org.openide.explorer.propertysheet.BaseTable.paintComponent(BaseTable.java:950)
   at org.openide.explorer.propertysheet.SheetTable.paintComponent(SheetTable.java:421)
   at javax.swing.JComponent.paint(JComponent.java:1005)
   at org.openide.explorer.propertysheet.BaseTable.paint(BaseTable.java:636)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JViewport.paint(JViewport.java:726)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1021)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at org.netbeans.core.windows.view.ui.MultiSplitPane.paint(MultiSplitPane.java:294)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JLayeredPane.paint(JLayeredPane.java:559)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at javax.swing.JLayeredPane.paint(JLayeredPane.java:559)
   at javax.swing.JComponent.paintChildren(JComponent.java:842)
   at javax.swing.JComponent.paint(JComponent.java:1014)
   at java.awt.GraphicsCallback$PaintCallback.run(GraphicsCallback.java:34)
   at sun.awt.SunGraphicsCallback.runOneComponent(SunGraphicsCallback.java:60)
   at sun.awt.SunGraphicsCallback.runComponents(SunGraphicsCallback.java:97)
   at java.awt.Container.paint(Container.java:1722)
   at org.netbeans.core.windows.view.ui.MainWindow.paint(MainWindow.java:509)
   at sun.awt.RepaintArea.paintComponent(RepaintArea.java:276)
   at sun.awt.RepaintArea.paint(RepaintArea.java:241)
   at apple.awt.ComponentModel.handleEvent(ComponentModel.java:251)
   at apple.awt.CWindow.handleEvent(CWindow.java:175)
   at java.awt.Component.dispatchEventImpl(Component.java:4097)
   at java.awt.Container.dispatchEventImpl(Container.java:2068)
   at java.awt.Window.dispatchEventImpl(Window.java:1774)
   at java.awt.Component.dispatchEvent(Component.java:3869)
   at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
   at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
   at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
   at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 3 Vladimir Yaroslavskiy 2007-08-09 14:44:44 UTC
*** Issue 111878 has been marked as a duplicate of this issue. ***
Comment 4 Vladimir Yaroslavskiy 2007-08-09 14:53:15 UTC
The problem is that IDE runs from root folder "/"
you can reproduce it from command lime/terminal:
$ cd /
$ /Users/<user>/netbeans/bin/netbeans

if you run from another folder, it works fine.

The same problem under Unix.
Comment 5 Vladimir Yaroslavskiy 2007-08-15 08:22:26 UTC
Removing PERFORMANCE keyword because the problem is in bug in xml retriever, not showing bpel diagram.
Comment 6 Vladimir Yaroslavskiy 2007-08-15 08:24:59 UTC
The issue is reproducible on UNIX too, for example SunOS dualhead 5.10 Generic i86pc.
Comment 7 Vladimir Yaroslavskiy 2007-08-23 10:01:22 UTC
Root issue has been fixed, so I'm closing this one.
Comment 8 Andrei Chistiakov 2007-08-28 12:57:27 UTC
Verified in build 200708280000.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo