Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 111842 - Editor hints popup disables editor
Editor hints popup disables editor
Status: RESOLVED DUPLICATE of bug 65326
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
Macintosh All
: P2 (vote)
: TBD
Assigned To: issues@editor
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 05:15 UTC by _ tboudreau
Modified: 2007-11-05 13:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2007-08-03 05:15:05 UTC
May be mac specific.  Not sure if it belongs here or the Java module.

Every now and then, I will press Alt-Enter to bring up the hints popup.  This may only happen when there are multiple hints:

When it appears I press the down arrow.  Nothing happens, the selected hint does not change.

The hints popup *will* respond correctly to mouse clicks.  If I click the hints popup, the correct hint will be performed.

BUT, if I do that, the editor stops responding to the keyboard.  Closing and reopening the file does not help.  I can position the caret line by clicking, but 
there is no caret.

My guess is that there is some boolean flag that toggles sending all keyboard events to the popup - and that sometimes the code that toggles it gets called 
twice, so it is diverting all key events from the editor when the popup is *off*, rather than onscreen.

Note it may be mac JDK 5 specific - text controls on JDK 5 on mac has a lot of problems with focus events - for example, it is easy to end up with the quick 
search popup in the Navigator with a blinking caret, while there is also a blinking caret in the editor and maybe a third blinking caret in the quick search 
popup in the editor.

However, the behavior - the editor stopping working completely and forcing shutdown (sometimes invoking another hint with the mouse will clear the 
condition, but I'm not sure exactly how to do it) is really bad.
Comment 1 Petr Hrebejk 2007-08-03 14:10:33 UTC
Tim, do you agree that this is a dupe?

*** This issue has been marked as a duplicate of 65326 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo