Bug 111463 - [60cat] Auto Comment tool missing in NB 6.0
[60cat] Auto Comment tool missing in NB 6.0
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Javadoc
6.x
All All
: P2 with 60 votes (vote)
: 6.x
Assigned To: Jan Lahoda
issues@java
: PLAN, REGRESSION
: 120759 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-31 13:08 UTC by tboerkel
Modified: 2010-12-14 05:48 UTC (History)
11 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
org-netbeans-modules-java-hints-analyzer.nbm (54.90 KB, application/octet-stream)
2008-04-04 13:15 UTC, Jan Becicka
Details
nbm for AU beta (53.60 KB, application/x-compressed)
2008-04-16 15:37 UTC, Jan Becicka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tboerkel 2007-07-31 13:08:30 UTC
The Auto Comment tool has been removed from NB 6.0. I consider this a bug. 

With Auto Comment, we were able to fix JavaDoc for a whole package very easily in one go. This was one of the key
advantages over Eclipse.
Comment 1 Jan Pokorsky 2007-08-02 10:38:27 UTC
The model over the AC was running has changed in NB 6.0. Our goal is to integrate AC features more tightly to the ide
within the rewrite to the new model. As a first step we implemented javadoc editor hints that permit to fix/generate
javadoc in an open editor. The integration with the tasklist allowing to run javadoc hints over several files will
follow but due to limited resources it will not be part of NB 6.0. We would like to add this to the autoupdate for NB
6.0 or to the next release.
Comment 2 javydreamercsw 2007-10-01 21:19:05 UTC
Same happened with me. I was just amazed about the superiority of NB 6.0 and boom! A simple but usefull/powerfull 
feature disappeared.

Shouldn't be removed until the new approach is up and running IMO.
Comment 3 javydreamercsw 2007-10-01 21:32:31 UTC
The hint feature kind of helps (Tools> Options> Java Code> Javadoc) but doesn't look the project/file for missing.
Comment 4 Jan Pokorsky 2007-10-02 16:12:56 UTC
Yes, the batch processing (project/package scope) is the last missing feature of the AU tool to replace.
Comment 5 mima 2007-10-08 10:27:34 UTC
Same for me. I used the autocomment feature daily and I think this is a step back.
Comment 6 knaeckebrot 2007-10-08 13:36:16 UTC
For me this was one of the most helpful features, I was shocked seeing it has been removed instead of being improved.
The new hint feature is nice, but will never replace the auto comment tool where I can edit Javadoc for all my methods
at once.
Comment 7 pdponce 2007-10-16 09:16:56 UTC
This was a useful feature in NB 5.5. I really think it should be put back in as it is a giant step backwards not having
it in.
Comment 8 erniep888 2007-10-18 20:19:55 UTC
Please, please bring back the auto comment or at least a viable replacement.  I agree with many previous comments; this
is a useful and productive feature that sets NB apart from Eclipse.
Comment 9 deeptinker 2007-10-22 03:12:55 UTC
I like the separate dialog for creating JavaDoc because it lets me focus on the "what" and "why".  It also gives me one
click access to common HTML tags (which reminds me to use them).

When I am writing code I am focused on the "how", so to create the JavaDoc entries then requires me to mentally shift
gears, which reduces my productivity.

So, IMHO, bringing back the Auto Comment tool would be more than just providing an alternate interface to the same
functionality.
Comment 10 _ manoelp 2007-10-25 18:27:54 UTC
	
Hello,

In my opinion, this tool is very important, someone knows where status is that correct?

Tks

Manoel Pimentel
Comment 11 rstaff 2007-10-25 19:58:56 UTC
More information can be found here:  http://java.sun.com/developer/community/askxprt/2007/jl1022.html.  See the
questions asked by Paranoid and Manuel Negri.

-------

I understand why the autocomment tool was removed, and I favor having tighter integration of javadoc editing, but if the
autocomment tool is not coming back then implementing the rest of the javadoc editing features needs to be completed as
soon as possible.
Comment 12 teinedraig 2007-10-31 00:05:35 UTC
Really miss the auto complete feature - was the only thing I was unhappy about with 6.0
Comment 13 vanob 2007-10-31 13:57:33 UTC
This issue has 33 votes. Why is it still P3? Should be at least P2.
Comment 14 Jan Pokorsky 2007-11-01 13:37:07 UTC
*** Issue 120759 has been marked as a duplicate of this issue. ***
Comment 15 jonathanglass 2007-11-09 22:01:48 UTC
I absolutely agree that the Auto Comment feature was great and that javadoc hints are not a suitable replacement.  At 
the very least users should have the option.  Thanks.
Comment 16 odepertat 2007-11-11 18:46:12 UTC
I totally. I manage dev teams and AUTOCOMMENT is a daily tool for code reviewing.
I missed so much that feature that javadoc hints do not replace that I have forbidden NetBeans 6.
This is a good advantage over Eclipse, please put it back !
ODP
Comment 17 liono 2007-11-14 15:53:43 UTC
This bug (thats what I consider it) brings back memories of other (non-java) projects where software was completely
rewritten thus re-introducing already solved bugs and leaving out "a few" features. For me the lack of autocomment will
likely weigh heavy enough to postpone an upgrade to 6.
Comment 18 greggwon 2007-11-14 18:27:33 UTC
Perhaps this tool makes use of JMI and the changes in 6.0 that removed JMI and did not provide a similar programming
model make it difficult to make this tool available?  I've asked before for such an API because I have tools that need
that as well.  If this is the issue, can we open a new issue that suggests that such an API is actually useful?  I've
not received much feedback on my request, so I've just assumed I'm in the minority on this need.
Comment 19 nleck 2007-11-14 20:26:30 UTC
yes, please put this feature back in. We need a way to batch fix the comments ( generally just before a check in). The
current method is not sufficient. Odd you had a nice feature and then removed it. 
Comment 20 kenhtanaka 2007-11-27 20:01:32 UTC
I'm voting to keep the Auto Comment feature intact until the new improved and integrated javadoc capabilities are available.
Comment 21 Jan Becicka 2007-12-06 13:58:54 UTC
Feature planned for 6.1.
Comment 22 khaipi 2007-12-11 12:52:31 UTC
Like everyone else, I was absolutely gob-smacked that this *feature* has been removed.  How can something so 
incredibly useful be removed *before* a replacement is implemented?  Please bring it back as soon as possible!  Also 
as mentioned, this feature really defined NetBeans for me and clearly distinguished it from Eclipse which lacks any 
such functionality.  I was looking forward to using it once more in NB 6.0 but amazingly it's not there anymore.
Comment 23 generation5org 2007-12-12 14:15:32 UTC
This is appalling -- NB 6.0 is awesome, but the complete lack of the Auto Comment feature is seriously making me 
consider moving back to a previous version.

Please, please, please bring it back...even as an optional module would be absolutely fine.
Comment 24 inorog 2007-12-26 11:52:52 UTC
Wheee! It's coming back in 6.1.

Thanks guys! :)
Comment 25 fragomez 2008-02-03 03:31:06 UTC
when is 6.1 coming? I would really like to have auto comment again soon.

Comment 26 William Leonard 2008-02-03 19:24:44 UTC
6.1 is scheduled for the end of April. This issue is scheduled for Milestone 2, which is scheduled for the beginning of
March. http://wiki.netbeans.org/NB61Milestones. -Brian
Comment 27 hiaw 2008-02-22 10:55:20 UTC
yes. I would love to see this feature back again.
Comment 28 _ manoelp 2008-02-22 11:45:33 UTC
It's a good news!

This feature is a great advantage for NetBeans IDE.

Tks,

Manoel Pimentel
Comment 29 jproto 2008-03-12 12:41:56 UTC
I vote for auto comment back.
I'd previously asked a WYSIWYG extension of this editor (http://www.netbeans.org/issues/show_bug.cgi?id=99246).

Chris.
Comment 30 Jan Pokorsky 2008-03-26 21:58:25 UTC
jlahoda works on this
Comment 31 fommil 2008-03-26 22:06:48 UTC
Must admit, I'm a little disappointed at the auto-comment tool in 6.1 beta.

In Eclipse, if I'm editing a Javadoc and I start to type the name of a class then auto-complete... it shows a list of relevant classes/methods and will do the 
autocompletion. In NetBeans, I have to do "{@link Blah[->complete]" before it will do the completion. It would be a whole lot more useable if the completion 
didn't require the "{@link" part to by typed first.

Also, wrapping of lines in Javadocs would be nice... but perhaps that is handled in another component.
Comment 32 Jan Becicka 2008-04-03 10:03:08 UTC
Attached NBM fixes original complaint, that there is no way, how to fix javadoc in whole package. Please test it and
give us feedback. We plan to integrate into dev builds soon and provide this module on AU.
Comment 33 jonr 2008-04-04 11:49:14 UTC
I'm adding my vote to the return of AutoComment. It was one of the two most helpful features of NB for me. 

BTW - can't get the .nbm to test the new module from the supplied url - 404. Is at available anywhere else?
Comment 34 Jan Becicka 2008-04-04 13:15:03 UTC
Created attachment 59673 [details]
org-netbeans-modules-java-hints-analyzer.nbm
Comment 35 Jan Becicka 2008-04-16 15:37:01 UTC
Created attachment 60282 [details]
nbm for AU beta
Comment 36 jonr 2008-04-19 22:22:42 UTC
Tested the new plugin on my stand-by machine (not yet using 6.1 for critical projects). At first glance it looks good. I
still prefer the old 5.5 auto comment in terms of the user interface but that may simply be because I'm more used to it. 

The new plugin covers most of the doc tags I use although I nice enhancement might be to allow the user to edit the
comment template that is inserted into the code for completion by the user. That would allow for the situation where a
user has local standards that require extra tags without making them type in the data every time a comment is inserted.

Thanks for this work.
Comment 37 nleck 2008-04-20 00:07:32 UTC
just installed the plugin in 6.1rc1 I can't see any new options... is there a screen shot of it working ? 
Comment 38 liono 2008-04-20 17:02:39 UTC
Having issued quite some negative criticism about NB6 in the past I too would like to compliment the work on the new
auto comment option in 6.1. I just did some testing on the rc2 version and I think NB6 is finally becoming more useable
again. It takes getting a bit used to it when coming from NB 5.5.1 (still using it on a daily basis) but I do agree that
this approach makes more sense; all control and features on the code screen. Great work you guys!
Comment 39 fpena 2008-04-25 16:57:35 UTC
Tested the new plugin on NB 6.1 RC2. It works very well. Still prefer Auto comment tool in NB 5.5 but it looks very well
too.

nleck, the new option is under Source menu (Source -> Analize Javadoc)
Comment 40 fommil 2008-04-25 17:10:05 UTC
I'm on 6.1 RC2 and I don't see any "Analyse Javadoc" entry there... in fact, my entire experience of the Javadoc support is that it can complete document 
annotations such as @deprecated and complete references to classes/methods if the user manually types "{@link " (it would be much better if autocomplete 
always assumed you wanted to insert a class name if you are typing a Capitalised word, or a method name otherwise) ... is there more to the tool than this? If 
so, where do I find the functionality?
Comment 41 fpena 2008-04-25 17:56:30 UTC
The plugin is attached on this issue (Attachments section). Download and install it.
Comment 42 deniss 2008-04-25 18:08:15 UTC
fommit, the is a "@link" issue 129468, you can vote for it.
Comment 43 Jan Lahoda 2008-06-04 10:16:43 UTC
The Analyze Javadoc is part of the standard trunk build:
http://hg.netbeans.org/main?cmd=changeset;node=136265b176f9
Comment 44 paresh11122 2010-12-14 05:48:38 UTC
If you have the opportunity, it may be worth your time to check out the quality cheap used cars for sale in Lafayette, LA.  Over the past several years, there have been an increasing amount of cars available on the used car market.  Recently, there has been a growing trend to place these used cars on online auction sites which makes it even easier to see whats available.  The key is deciding where you want to get your used cars from.
========================================
<a href="http://used.gov-auctions.org" rel="dofollow">used cars for sale</a>


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo