Bug 110965 - I18N - Error when create ws client with Multibyte characters
I18N - Error when create ws client with Multibyte characters
Status: RESOLVED WONTFIX
Product: webservices
Classification: Unclassified
Component: Client
6.x
All All
: P2 (vote)
: TBD
Assigned To: Milan Kuchtiak
issues@webservices
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 15:52 UTC by Jaroslav Pospisil
Modified: 2008-02-06 16:08 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (49.09 KB, text/plain)
2007-07-25 15:53 UTC, Jaroslav Pospisil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Pospisil 2007-07-25 15:52:34 UTC
Build 200707211200, JDK1.6.0_02, Windows Vista

1)Start IDE with new userdir
2)Create new EJB module,let name default
3)Add web service client to this URL: http://www.esynaps.com/WebServices/SearchWS.asmx?WSDL and enter multibyte
name for package.
ERROR: Build fails - attaching messages.log

NOTICE: If I use non-multibyte name of package,client builds O.K.
Comment 1 Jaroslav Pospisil 2007-07-25 15:53:09 UTC
Created attachment 45684 [details]
messages.log
Comment 2 Jaroslav Pospisil 2007-07-25 17:00:23 UTC
wsimport-client-compile output:

と粮Joe粮init:粤ろ
と粮Joe粮wsimport-init:粤ろ
と粮Joe粮wsimport-client-check-SearchWS.asmx:粤ろ
と粮Joe粮wsimport-client-SearchWS.asmx:粤ろ
と粮Joe粮wsimport-client-generate:粤ろ
と粮Joe粮wsimport-client-compile:粤ろ
Compiling 6 source files to C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\jar
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
ObjectFactory.java:2: 警告:この文字は、エンコーディング UTF-8 にマップできません。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
ObjectFactory.java:2: 警告:この文字は、エンコーディング UTF-8 にマップできません。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
ObjectFactory.java:10: 警告:この文字は、エンコーディング UTF-8 にマップできません。
 * generated in the ??e package. 
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
ObjectFactory.java:10: 警告:この文字は、エンコーディング UTF-8 にマップできません。
 * generated in the ??e package. 
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
ObjectFactory.java:26: 警告:この文字は、エンコーディング UTF-8 にマップできません。
     * Create a new ObjectFactory that can be used to create new instances of schema derived classes for package: ??e
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
ObjectFactory.java:26: 警告:この文字は、エンコーディング UTF-8 にマップできません。
     * Create a new ObjectFactory that can be used to create new instances of schema derived classes for package: ??e
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
ObjectFactory.java:2: \65533 は不正な文字です。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
ObjectFactory.java:2: \65533 は不正な文字です。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
Search.java:2: 警告:この文字は、エンコーディング UTF-8 にマップできません。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
Search.java:2: 警告:この文字は、エンコーディング UTF-8 にマップできません。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
Search.java:2: \65533 は不正な文字です。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
Search.java:2: \65533 は不正な文字です。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
SearchResponse.java:2: 警告:この文字は、エンコーディング UTF-8 にマップできません。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
SearchResponse.java:2: 警告:この文字は、エンコーディング UTF-8 にマップできません。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
SearchResponse.java:2: \65533 は不正な文字です。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
SearchResponse.java:2: \65533 は不正な文字です。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:2: 警告:この文字は、エンコーディング UTF-8 にマップできません。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:2: 警告:この文字は、エンコーディング UTF-8 にマップできません。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:26: 警告:この文字は、エンコーディング UTF-8 にマップできません。
    private final static Logger logger = Logger.getLogger(??e.WebSearchWS.class.getName());
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:26: 警告:この文字は、エンコーディング UTF-8 にマップできません。
    private final static Logger logger = Logger.getLogger(??e.WebSearchWS.class.getName());
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:32: 警告:この文字は、エンコーディング UTF-8 にマップできません。
            baseUrl = ??e.WebSearchWS.class.getResource(".");
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:32: 警告:この文字は、エンコーディング UTF-8 にマップできません。
            baseUrl = ??e.WebSearchWS.class.getResource(".");
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:2: \65533 は不正な文字です。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:2: \65533 は不正な文字です。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:26: \65533 は不正な文字です。
    private final static Logger logger = Logger.getLogger(??e.WebSearchWS.class.getName());
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:26: \65533 は不正な文字です。
    private final static Logger logger = Logger.getLogger(??e.WebSearchWS.class.getName());
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:26: <identifier> がありません。
    private final static Logger logger = Logger.getLogger(??e.WebSearchWS.class.getName());
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:26: <identifier> がありません。
    private final static Logger logger = Logger.getLogger(??e.WebSearchWS.class.getName());
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:32: \65533 は不正な文字です。
            baseUrl = ??e.WebSearchWS.class.getResource(".");
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:32: \65533 は不正な文字です。
            baseUrl = ??e.WebSearchWS.class.getResource(".");
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:41: メソッドの宣言が不正です。戻り値の型が必要です。
    public WebSearchWS(URL wsdlLocation, QName serviceName) {
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:45: メソッドの宣言が不正です。戻り値の型が必要です。
    public WebSearchWS() {
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWS.java:71: 構文解析中にファイルの終わりに移りました
}
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWSSoap.java:2: 警告:この文字は、エンコーディング UTF-8 にマップできません。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWSSoap.java:2: 警告:この文字は、エンコーディング UTF-8 にマップできません。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWSSoap.java:2: \65533 は不正な文字です。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
WebSearchWSSoap.java:2: \65533 は不正な文字です。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
package-info.java:2: 警告:この文字は、エンコーディング UTF-8 にマップできません。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
package-info.java:2: 警告:この文字は、エンコーディング UTF-8 にマップできません。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
package-info.java:2: \65533 は不正な文字です。
package ??e;
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\build\generated\wsimport\client\内容\
package-info.java:2: \65533 は不正な文字です。
package ??e;
エラー 21 個
警告 20 個
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\nbproject\jaxws-build.xml:37: The
following error occurred while executing this line:
C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule5粤ろ\nbproject\build-impl.xml:129: Compile
failed; see the compiler error output for details.
BUILD FAILED (total time: 0 seconds)
Comment 3 Milan Kuchtiak 2007-08-03 12:48:16 UTC
Likely problem in Netbeans with xsl transformation.

Reporter, please, send the content of jax-ws.xml and jaxws-build.xml.
Comment 4 Jaroslav Pospisil 2007-08-07 13:25:07 UTC
This is how wsimport is called in console:

wsimport -d C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule6粤ろ\build\generated\wsimport\
binaries -extension -keep -s C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule6粤ろ\build\
generated\wsimport\client -catalog C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule6粤ろ\
catalog.xml -verbose C:\Users\jp154641\Documents\と粮Joi粮NetBeansProjects粤ろ\と粮Jot粮EJBModule6粤ろ/src/conf/xml-
resources/web-service-references/SearchWS.asmx/wsdl/www.esynaps.com/WebServices/SearchWS.asmx.wsdl -p 原本の
-wsdllocation http://www.esynaps.com/WebServices/SearchWS.asmx?WSDL

Also multibyte package name is correct everywhere other than in generated client java classes (attaching Search.java)
Comment 5 Jaroslav Pospisil 2007-08-07 13:26:59 UTC
After rethinking I'm attaching instead whole EJB project in zip.
Comment 6 Jaroslav Pospisil 2007-08-07 13:50:57 UTC
So zip doesn't support multibyte, I can't zip the project. If there'll be need of it,I'm able to create rar or maybe tar
archive.
Comment 7 Milan Kuchtiak 2007-08-07 13:54:26 UTC
Thanks for the debug message from wsimport.
All values for wsimport are generated correctly.
 
The problem is on JAX-WS runtime side. The generated java artifacts have incorrect package string.
BTW, the package itself is generated correctly. 

I filed an issue to jAX-WS team :
https://jax-ws.dev.java.net/issues/show_bug.cgi?id=397
Comment 8 Ken Frank 2007-08-07 16:50:41 UTC
can someone summarize the limitation and scenarios for nb users because of this  jax problem ?

that is, for doing what things can multibyte not be used ?

ken.frank@sun.com
Comment 9 Jaroslav Pospisil 2008-02-06 16:08:44 UTC
I've reproduced the same issue,this time in Web Application with Build 200802051752,JDK1.6.0_04,Win Vista .
It's not fixed after half of year on the JAX-WS side, maybe it isn't bad idea to raise issue's priority .  


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo