Bug 110904 - FileChooser starts many "Basic L&F File Loading Thread"s
FileChooser starts many "Basic L&F File Loading Thread"s
Status: RESOLVED DUPLICATE of bug 179124
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
issue_reviewed
: PERFORMANCE, THREAD
: 152461 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 11:28 UTC by Petr Nejedly
Modified: 2010-03-23 16:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Nejedly 2007-07-25 11:28:51 UTC
Clean IDE build, clean user dir, invoked Open project. The operation was slow (due to high filesystem contention,
external to the IDE), but a thread dump revealed several (6 from L&F + 2 ours) threads trying lo list the folder.
I believe those 6 "Basic L&F File Loading Thread" are wrong (only one folder is listed using single filechooser).
Needs investigation, thus assigning to performance
Comment 1 David Simonek 2008-07-25 13:42:32 UTC
Hmm, there is something dirty probably.
Comment 2 David Simonek 2008-11-21 15:50:06 UTC
*** Issue 152461 has been marked as a duplicate of this issue. ***
Comment 3 David Simonek 2010-03-23 16:25:53 UTC
Should be fixed along with 179124 fix, there was several unneeded requests for rescanning current directory which I eliminated.

*** This bug has been marked as a duplicate of bug 179124 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo