Bug 110882 - Profiler doesn't run with embedded Tomcat
Profiler doesn't run with embedded Tomcat
Status: RESOLVED DUPLICATE of bug 103046
Product: profiler
Classification: Unclassified
Component: Base
6.x
Macintosh All
: P3 (vote)
: 6.x
Assigned To: Tomas Hurka
issues@profiler
http://weblogs.java.net/blog/fabrizio...
it070918 fix-in-60 it070925
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 09:25 UTC by fabriziogiudici
Modified: 2007-10-31 13:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fabriziogiudici 2007-07-25 09:25:32 UTC
The profiler doesn't work with the embeeded Tomcat; trying to start it in "profiling mode" gives an error message about the profiling agent not found.

I discovered that this is due to the presence of spaces in classpaths (that is, in the installation folder of NetBeans 6). My NB6 got installed in

/Users/fritz/Applications/NetBeans 6.0M10.app

(being /Applications/NetBeans 6.0M10.app the default, I just prepended my home directory). Inside the bundle there's the directory:

/Users/fritz/Applications/NetBeans 6.0M10.app/Contents/Resources/NetBeans 6.0M10

with another space between 6.0M10. Removing both of spaces (and fixing two symlinks) the profiler works fine.

I didn't test this on other o.s. yet, so at the moment I'm filing this as Mac OS X specific. BTW, Java startup scripts are usually still fragile with respect of the 
presence of spaces in the classpaths, so it could be a general idea to avoid them not only for this profiler bug, but as they could originate other problems.
Comment 1 Tomas Hurka 2007-07-25 09:46:53 UTC
Probably duplicate of issue #103047
Comment 2 fabriziogiudici 2007-07-25 09:55:24 UTC
Probably it's so. I saw 103047, but I filed a different issue since I'm working with NB6M10 (not M9) and Tomcat 6.0.13 (not 5.5.23), and the error I get is 
different. It probably depends on how it will be fixed: removing the spaces and declaring them illegal in any installation will fix both; otherwise, I think that 
these two bugs could require similar but multiple fixes in Tomcat scripts.
Comment 3 Tomas Hurka 2007-10-31 13:32:37 UTC

*** This issue has been marked as a duplicate of 103046 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo