Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 110685 - [A11Y] After wrong expression evaluated in EE dialog focus is moved to editor
[A11Y] After wrong expression evaluated in EE dialog focus is moved to editor
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
61fixes1-fixed
: A11Y
: 132175 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-24 09:06 UTC by ehucka
Modified: 2008-06-04 08:39 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ehucka 2007-07-24 09:06:20 UTC
Product Version: NetBeans IDE Dev (Build 200707240000) Java: 1.6.0_02; Java HotSpot(TM) Client VM 1.6.0_02-b05 System:
Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

Try to write some wrong expression in Evaluate Expression dialog and confirm the Information dialog - cursor is moved
into editor window. EE dialog loses focus.
Comment 1 Martin Entlicher 2007-08-23 15:13:56 UTC
Well, on Linux with focus-follows-mouse (my default setup) it depends on where your mouse is. Thus it works fine when
your mouse is upon Evaluate Expression window.

When I turn off the focus-follows-mouse behavior, then the focus stays in the Evaluate Expression dialog... Strange.

Really, it should work fine. I've looked into org.netbeans.core.windows.services.createDialog() and the logic looks fine.
Comment 2 Martin Entlicher 2007-08-23 15:17:21 UTC
Does not seem to be serious enough for P3 priority.
Comment 3 Martin Entlicher 2008-04-09 16:12:02 UTC
*** Issue 132175 has been marked as a duplicate of this issue. ***
Comment 4 Jiri Vagner 2008-04-24 07:19:41 UTC
I discussed this issue with Martin Entlicher and he promised to fix this into nb61 patch1. Martin agreed with me that
this bug is very annoying for users. >> Increasing priority to P3
Comment 5 Martin Entlicher 2008-04-24 09:45:48 UTC
Fixed in trunk:
http://hg.netbeans.org/main/rev/db2bcd23740c
Comment 6 Quality Engineering 2008-04-24 15:51:00 UTC
Issue '110685' Integrated in NB_Trunk_Production #155 : http://hg.netbeans.org/main/rev/db2bcd23740c,
 with comment: #110685 - Assure that the focus is moved back to the Evaluator field when the error dialog is closed.
Comment 7 Jiri Vagner 2008-04-25 06:46:58 UTC
Verified

Product Version: NetBeans IDE Dev (Build 200804250004)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)
Comment 8 rbalada 2008-04-25 16:59:58 UTC
Merged into release61_fixes repository

changeset:   77445:9049a711a902
user:        mentlicher@netbeans.org
date:        Thu Apr 24 10:35:22 2008 +0200
summary:     #110685 - Assure that the focus is moved back to the Evaluator field when the error dialog is closed.
Comment 9 Martin Entlicher 2008-04-26 21:22:41 UTC
Actually, this fix has caused a regression in the behavior of the combo box popup menu. The focus transfer caused
flickering and made the popup unusable.

This regression is fixed now just in trunk:

changeset:   79269:988c9c24d5bb
http://hg.netbeans.org/main/rev/988c9c24d5bb
Comment 10 rbalada 2008-04-28 08:31:32 UTC
jvagner,

would you please re-verify the second fix in trunk?

Removed the "release61_fixes_fixed" keyword from Status whiteboard to reflect current state of waiting for second fix
verification.
Comment 11 Jiri Vagner 2008-04-28 09:47:53 UTC
Re-verified

Product Version: NetBeans IDE Dev (Build 200804280002)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)
Comment 12 rbalada 2008-04-28 15:00:41 UTC
I've transplanted the second fix [1] from main into release61_branch [2]

changeset:   77463:a50a4272061d
tag:         tip
user:        mentlicher@netbeans.org
date:        Sat Apr 26 22:12:35 2008 +0200
summary:     110685 - Repair of flickering of the ComboBox popup menu. It was caused by the focus transfer.

[1] http://hg.netbeans.org/main/rev/988c9c24d5bb
[2] http://hg.netbeans.org/release61_fixes/rev/a50a4272061d
Comment 13 Peter Pis 2008-05-19 10:00:43 UTC
Verified on Patch1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo