Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 110495 - "Assignment To Itself" incorrectly given
"Assignment To Itself" incorrectly given
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Hints
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Petr Hrebejk
issues@java
:
: 112078 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-21 16:27 UTC by err
Modified: 2007-09-01 10:35 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
specific code involved with bogus warning (7.67 KB, image/png)
2007-07-21 16:29 UTC, err
Details

Note You need to log in before you can comment on or make changes to this bug.
Description err 2007-07-21 16:27:26 UTC
Build 200707200000
With two objects of same type, "obj1.field = obj2.field" gives warning.
Screenshot attached showing details.
Comment 1 err 2007-07-21 16:29:37 UTC
Created attachment 45484 [details]
specific code involved with bogus warning
Comment 2 Jan Lahoda 2007-07-27 09:45:14 UTC
Seems like dupe of issue #106408 to me. Thanks for the report.

*** This issue has been marked as a duplicate of 106408 ***
Comment 3 err 2007-07-27 14:40:01 UTC
Reopening.  Issue 106408 was closed on July 11, this is reported against 20070720. I tried it with 2007270000 (this
mornings build) and the problem is still there. Here is a complete .java file that reproduces the problem:

import java.awt.Dimension;
import java.awt.Toolkit;
import javax.swing.JFrame;
public class NewClass {
    JFrame frame = null;
    Dimension s = Toolkit.getDefaultToolkit().getScreenSize();
    Dimension f = frame.getSize();
    void meth() {
        if(f.height > s.height)
            f.height = s.height;
    }
}

========
Product Version: NetBeans IDE Dev (Build 200707270000) Java: 1.6.0_02; Java HotSpot(TM) Client VM 1.6.0_02-b06 System:
Windows XP version 5.1 running on x86; Cp1252; en_US (nb) Userdir: C:\Documents and Settings\erra\.netbeans\dev
Comment 4 Jiri Prox 2007-08-07 08:38:48 UTC
*** Issue 112078 has been marked as a duplicate of this issue. ***
Comment 5 Petr Hrebejk 2007-08-27 16:12:16 UTC
Checking in AssignmentToItself.java;
/cvs/java/hints/src/org/netbeans/modules/java/hints/AssignmentToItself.java,v  <--  AssignmentToItself.java
new revision: 1.6; previous revision: 1.5
done
Comment 6 athompson 2007-08-30 15:15:49 UTC
yup. can we turn the option back on again by default?
Comment 7 Petr Hrebejk 2007-09-01 10:35:43 UTC
Checking in AssignmentToItself.java;
/cvs/java/hints/src/org/netbeans/modules/java/hints/AssignmentToItself.java,v  <--  AssignmentToItself.java
new revision: 1.7; previous revision: 1.6


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo