Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 110060 - NPE when accessing properties on WSDL port widget
NPE when accessing properties on WSDL port widget
Status: VERIFIED DUPLICATE of bug 110218
Product: soa
Classification: Unclassified
Component: Composite Application
6.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: Jun Qian
issues@soa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-17 19:31 UTC by jlautz
Modified: 2008-04-09 16:26 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Reload dialog (130.98 KB, application/octet-stream)
2007-07-17 19:37 UTC, jlautz
Details
Stacktrace for NullPointerException (2.84 KB, application/octet-stream)
2007-07-17 19:59 UTC, jlautz
Details
Log file for NB scenario. (89.21 KB, application/octet-stream)
2007-07-17 20:03 UTC, jlautz
Details
Projects at end of scenario (saved after NPE). (78.43 KB, application/octet-stream)
2007-07-17 20:06 UTC, jlautz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jlautz 2007-07-17 19:31:29 UTC
Seen in 

Steps to reproduce (you must follow the steps exactly, and perhaps only on a slower Windows machine):
1. Create SynchronousSample.
2. Define a new composite app.
3. Open CASA
4. DnD the SynchronousSample project into the new composite app JBI Modules area.
5. Click the Build Project button. 
6. DnDrop a File Binding
7. Make a connection between the File port Consumer and SOAP port Provider. (DO NOT build or save the project.)
8. Select the File Port Consumes endpoint and rt click on Properties to open the Properties dialog.
9. In the Properties dialog, click on the Browser button for Interface, then Cancel.
10. In the Properties dialog, click on the Browser button for Service Name, then Cancel.
11. Click Cancel to exit the Properties dialog.

=> I get the dialog with msg "File <filepath/filename> was modified externally. Reload it?" (screenshot attached)

12. Click Yes.

13. Select the File port, and rt-click on Properties to open the Properties dialog for the File port.

=> NPE. stacktrace attached.

Project files attached.
Comment 1 jlautz 2007-07-17 19:35:04 UTC
Seen with build 200707171200 on Windows XP with JDK 1.6_01.

Step 11 should be click Close button.

Log will also be attached.
Comment 2 jlautz 2007-07-17 19:37:23 UTC
Created attachment 45246 [details]
Reload dialog
Comment 3 jlautz 2007-07-17 19:59:35 UTC
Created attachment 45247 [details]
Stacktrace for NullPointerException
Comment 4 jlautz 2007-07-17 20:03:36 UTC
Created attachment 45248 [details]
Log file for NB scenario.
Comment 5 jlautz 2007-07-17 20:06:21 UTC
Created attachment 45251 [details]
Projects at end of scenario (saved after NPE).
Comment 6 Jun Qian 2007-07-24 03:25:27 UTC
I can't reproduce this, but I think the cause should be the same as #110218. Please verify.
Comment 7 jlautz 2007-08-22 17:49:42 UTC
Going to set as duplicate of issue 110218.
Comment 8 jlautz 2007-08-22 17:50:02 UTC

*** This issue has been marked as a duplicate of 110218 ***
Comment 9 jlautz 2008-04-09 16:26:17 UTC
Verified not reproduceable.


Product Version: NetBeans IDE Dev (Build 200804040802) - Java CAPS Enabled
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: SunOS version 5.10 running on x86; ISO646-US; en (nb)
Userdir: /Users/lautz/sierrabuilds/JavaCAPS20080406/.netbeans/caps


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo