Bug 109887 - org.openide.filesystems.FileAlreadyLockedException
org.openide.filesystems.FileAlreadyLockedException
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
5.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Milos Kleint
issues@projects
: RANDOM, THREAD
: 113229 114553 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-16 18:26 UTC by rofenv
Modified: 2007-09-10 13:21 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
org.openide.filesystems.FileAlreadyLockedException: Services/org-netbeans-modules-project-ui-OpenProjectList.settings (223.88 KB, text/plain)
2007-07-16 18:29 UTC, rofenv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rofenv 2007-07-16 18:26:37 UTC
org.openide.filesystems.FileAlreadyLockedException: Services/org-netbeans-modules-project-ui-OpenProjectList.settings
	at org.openide.filesystems.MultiFileObject.lock(MultiFileObject.java:562)
[catch] at org.netbeans.modules.settings.ScheduledRequest.schedule(ScheduledRequest.java:83)
	at org.netbeans.modules.settings.ScheduledRequest.schedule(ScheduledRequest.java:74)
	at org.netbeans.modules.settings.convertors.SerialDataConvertor$SaveSupport.propertyChange
(SerialDataConvertor.java:703)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:276)
	at org.openide.util.SharedClassObject.firePropertyChange(SharedClassObject.java:424)
	at org.openide.options.SystemOption.firePropertyChange(SystemOption.java:113)
	at org.openide.options.SystemOption.readExternal(SystemOption.java:380)
	at org.openide.util.SharedClassObject$WriteReplace.readObject(SharedClassObject.java:695)
	at sun.reflect.GeneratedMethodAccessor17.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at java.io.ObjectStreamClass.invokeReadObject(ObjectStreamClass.java:974)
	at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1846)
	at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1753)
	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1329)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
	at org.netbeans.modules.settings.convertors.XMLSettingsSupport$SettingsRecognizer.readSerial
(XMLSettingsSupport.java:520)
	at org.netbeans.modules.settings.convertors.XMLSettingsSupport$SettingsRecognizer.instanceCreate
(XMLSettingsSupport.java:548)
	at org.netbeans.modules.settings.convertors.SerialDataConvertor$SettingsInstance.instanceCreate
(SerialDataConvertor.java:371)
	at org.netbeans.modules.settings.convertors.SerialDataConvertor.instanceCookieChanged
(SerialDataConvertor.java:198)
	at org.netbeans.modules.settings.convertors.SerialDataConvertor.propertyChange(SerialDataConvertor.java:223)
	at org.netbeans.modules.settings.convertors.SerialDataConvertor.fileChanged(SerialDataConvertor.java:232)
	at sun.reflect.GeneratedMethodAccessor11.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:416)
	at $Proxy1.fileChanged(Unknown Source)
	at org.openide.filesystems.FCLSupport.dispatchEvent(FCLSupport.java:88)
	at org.openide.filesystems.FileObject$ED.dispatch(FileObject.java:807)
	at org.openide.filesystems.EventControl.invokeDispatchers(EventControl.java:185)
	at org.openide.filesystems.EventControl.exitAtomicAction(EventControl.java:159)
	at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:104)
	at org.openide.filesystems.FileSystem.runAtomicAction(FileSystem.java:456)
	at org.netbeans.modules.settings.convertors.SerialDataConvertor$SaveSupport.writeDown
(SerialDataConvertor.java:795)
	at org.netbeans.modules.settings.convertors.SerialDataConvertor$SaveSupport.access$200
(SerialDataConvertor.java:474)
	at org.netbeans.modules.settings.convertors.SerialDataConvertor.run(SerialDataConvertor.java:295)
	at org.netbeans.modules.settings.ScheduledRequest.performRequest(ScheduledRequest.java:174)
	at org.netbeans.modules.settings.ScheduledRequest.run(ScheduledRequest.java:148)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:499)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:932)
Comment 1 rofenv 2007-07-16 18:29:16 UTC
Created attachment 45153 [details]
org.openide.filesystems.FileAlreadyLockedException: Services/org-netbeans-modules-project-ui-OpenProjectList.settings
Comment 2 Milos Kleint 2007-07-24 10:34:54 UTC
the 6.0 codebase uses different means of persisting and reading settings - Preferences API.
So it's basically fixed (as the code in the stacktraces is not called and is gone from product)
Comment 3 Peter Pis 2007-09-10 13:20:19 UTC
*** Issue 114553 has been marked as a duplicate of this issue. ***
Comment 4 Peter Pis 2007-09-10 13:21:00 UTC
*** Issue 113229 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo