Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 109478 - [cc] is not updated for changes in tagfiles
[cc] is not updated for changes in tagfiles
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: JSP Parser
6.x
Sun All
: P3 (vote)
: 6.x
Assigned To: issues@javaee
issues@javaee
release601_fixes_candidate2, release6...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-12 09:52 UTC by Jindrich Sedek
Modified: 2016-07-07 08:54 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
screen shot (95.23 KB, image/png)
2007-07-12 09:52 UTC, Jindrich Sedek
Details
patch for JSP Core (4.41 KB, text/plain)
2008-03-01 21:13 UTC, Tomas Mysik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2007-07-12 09:52:02 UTC
Create new WebApplication
create new tag library
Create new tagFile and add it into library
add this line into index.jsp:
<%@ taglib prefix="library"  uri="/WEB-INF/tlds/library"%>

type <library:| and press Ctrl+Space to invoke cc in index.jsp
tag file is completed

open tag file add some required attribute:

<%@attribute name="title" required="true"%>


go back to index.jsp:
there is an error highlighted for library tag because of missing required attribute, but it's not offered by code completion
Comment 1 Jindrich Sedek 2007-07-12 09:52:36 UTC
Created attachment 44994 [details]
screen shot
Comment 2 Marek Fukala 2007-07-13 09:27:23 UTC
Code completion takes the results from jsp parser so in this case it looks like erroneous data caching in the jsp parser. 
Comment 3 Petr Pisl 2007-10-15 15:44:34 UTC
The problem is that jspparser parses the page after a change in the page. If you create a page in the jsp, then the cc
works correctly?
Comment 4 Jindrich Sedek 2007-10-15 16:39:28 UTC
I'm can reproduce this problem, but it seems that cc is refreshed after first edit action in jsp page. This is P4 issue 
for me now - it was probably partially fixed in lates changes in jsp parser.
Comment 5 Jindrich Sedek 2008-02-27 08:57:33 UTC
This problem has became more serious probably after latest changes in jsp parser -> no attributes are updated in
completion nor in error highlighting. 
Use scenario described above, change tagfile attributes (rename, add, remove), no changes are propagated into jsp page.
Reopening jsp page doesn't help. Just ide restart works for me to update data in cc -> increasing priority.
Comment 6 Tomas Mysik 2008-02-27 09:14:49 UTC
Jindro, is there any change/regression in comparison with NB 6.0/5.5? Thanks.
Comment 7 Jindrich Sedek 2008-02-27 09:49:08 UTC
In 6.0 attributes error highlighting was updated correctly and code completion was not always updated as described in
this issue, but it was updated after closing and reopening file. Actual behavior doesn't update after reopening page and
highlighting is not updated either.
Comment 8 Tomas Mysik 2008-02-27 09:58:55 UTC
OK, thanks for clarification.
Comment 9 Tomas Mysik 2008-02-27 10:35:07 UTC
Jindro, could you please try NB dev build from 20th of february? After that date I made some changes which could be 
related to this regression. Thanks a lot.
Comment 10 Jindrich Sedek 2008-02-27 10:56:25 UTC
I've tryed it on 200802191203 and doesn't work as well.
Comment 11 Tomas Mysik 2008-02-27 16:12:23 UTC
Fixed, please verify. Btw feel free to leave this issue reopened as a reminder for not refreshing of a page. Thanks.

changeset:   69898:bded5870b4f2
tag:         tip
user:        Tomas Mysik <tmysik@netbeans.org>
date:        Wed Feb 27 16:31:31 2008 +0100
summary:     #109478: [cc] is not updated for changes in tagfiles

Adding Marek to CC because I think that we could probably solve the issue with not refreshing of a page (see the 
comment 'jsedek Mon Oct 15 15:39:28 +0000 2007'). Now, JSP parser could fire event after its cache is recreated, 
TagLibParseSupport could be listening to it. What do you think about it? Thanks.
Comment 12 Tomas Mysik 2008-02-29 17:02:41 UTC
To my previous comment - it's possible, I have working prototype.
So reopening, lowering priority and removing REGRESSION keyword.
Comment 13 Tomas Mysik 2008-03-01 21:12:19 UTC
I've done needed changes in JSP Parser. Marku, would it be possible to review patch for JSP Core? It's not completely 
working, if the tab is not shown then the refresh does not work. But I hope it will be doable. Thanks.
Comment 14 Tomas Mysik 2008-03-01 21:13:32 UTC
Created attachment 57610 [details]
patch for JSP Core
Comment 15 Tomas Mysik 2008-03-03 12:56:14 UTC
Reassigning after a discussion with Marek. See my last comments for more information. Thanks.
Comment 16 rbalada 2008-03-13 14:14:53 UTC
I'm going to backport fix for this issue to release601_fixes branch.
Comment 17 rbalada 2008-03-13 14:18:01 UTC
I've backported changeset http://hg.netbeans.org/main?cmd=changeset;node=bded5870b4f2 to release601_fixes branch

IDE: [3/13/08 2:15 PM] Committing "WebAppParseSupport.java" started
Checking in WebAppParseSupport.java;
/cvs/web/jspparser/extsrc/org/netbeans/modules/web/jspparser_ext/Attic/WebAppParseSupport.java,v  <-- 
WebAppParseSupport.java
new revision: 1.14.8.3; previous revision: 1.14.8.2
done
IDE: [3/13/08 2:15 PM] Committing "WebAppParseSupport.java" finished
Comment 18 Jiri Prox 2008-04-11 01:15:27 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 19 Marek Fukala 2008-08-22 12:45:59 UTC
the patch looks ok to me, go ahead and integrate if you still need it.
Comment 20 Tomas Mysik 2008-08-22 14:26:26 UTC
Changing to ENHANCEMENT, I think that the patch didn't work correctly - when one switches to different tab 
(file), "something" is not called/updated (there were no errors visible, only after some change so no improvement at 
all). I will try to look at it.
Comment 21 Martin Balin 2016-07-07 08:54:02 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo