Bug 109288 - OS dependency should differentiate between Solaris and Linux
OS dependency should differentiate between Solaris and Linux
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Module System
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jesse Glick
issues@platform
: API, API_REVIEW_FAST
: 109324 109466 (view as bug list)
Depends on:
Blocks: 109160
  Show dependency treegraph
 
Reported: 2007-07-10 20:36 UTC by Martin Ryzl
Modified: 2008-12-22 13:32 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Proposed patch (9.59 KB, patch)
2007-07-11 20:12 UTC, Jesse Glick
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Ryzl 2007-07-10 20:36:48 UTC
Currently only org.openide.modules.os.Unix token is available as OS dependency:
http://www.netbeans.org/download/dev/javadoc/org-openide-modules/org/openide/modules/doc-files/api.html#how-os-specific

Since some runtimes distributed through UC are available as Solaris and Linux version it confuses user.
Comment 1 Adam Sotona 2007-07-11 08:51:03 UTC
*** Issue 109324 has been marked as a duplicate of this issue. ***
Comment 2 Jesse Glick 2007-07-11 20:11:45 UTC
Please review this simple API enhancement, which blocks a P2 DEFECT.
Comment 3 Jesse Glick 2007-07-11 20:12:05 UTC
Created attachment 44970 [details]
Proposed patch
Comment 4 Jesse Glick 2007-07-12 17:00:14 UTC
*** Issue 109466 has been marked as a duplicate of this issue. ***
Comment 5 Jaroslav Tulach 2007-07-13 10:39:09 UTC
OK
Comment 6 Jesse Glick 2007-07-18 19:15:18 UTC
Back to me to implement.
Comment 7 Jesse Glick 2007-07-18 19:17:05 UTC
Checking in openide/modules/apichanges.xml;
/shared/data/ccvs/repository/openide/modules/apichanges.xml,v  <--  apichanges.xml
new revision: 1.10; previous revision: 1.9
done
Checking in openide/modules/manifest.mf;
/shared/data/ccvs/repository/openide/modules/manifest.mf,v  <--  manifest.mf
new revision: 1.14; previous revision: 1.13
done
Checking in openide/modules/src/org/openide/modules/doc-files/api.html;
/shared/data/ccvs/repository/openide/modules/src/org/openide/modules/doc-files/api.html,v  <--  api.html
new revision: 1.15; previous revision: 1.14
done
Checking in core/startup/src/org/netbeans/core/startup/ConsistencyVerifier.java;
/shared/data/ccvs/repository/core/startup/src/org/netbeans/core/startup/ConsistencyVerifier.java,v  <-- 
ConsistencyVerifier.java
new revision: 1.2; previous revision: 1.1
done
Checking in core/startup/src/org/netbeans/core/startup/NbInstaller.java;
/shared/data/ccvs/repository/core/startup/src/org/netbeans/core/startup/NbInstaller.java,v  <--  NbInstaller.java
new revision: 1.43; previous revision: 1.42
done
Checking in core/startup/test/unit/src/org/netbeans/core/startup/ConsistencyVerifierTest.java;
/shared/data/ccvs/repository/core/startup/test/unit/src/org/netbeans/core/startup/ConsistencyVerifierTest.java,v  <-- 
ConsistencyVerifierTest.java
new revision: 1.2; previous revision: 1.1
done
Checking in core/startup/test/unit/src/org/netbeans/core/startup/PlatformDependencySatisfiedTest.java;
/shared/data/ccvs/repository/core/startup/test/unit/src/org/netbeans/core/startup/PlatformDependencySatisfiedTest.java,v
 <--  PlatformDependencySatisfiedTest.java
new revision: 1.7; previous revision: 1.6
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo