Bug 108941 - REGRESSION: External schema is not imported in WSDL when walking through New WSDL Document wizard
REGRESSION: External schema is not imported in WSDL when walking through New ...
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: WSDL Tools
6.x
PC All
: P1 (vote)
: 6.x
Assigned To: Shivanand Kini
issues@xml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-05 12:43 UTC by Andrei Chistiakov
Modified: 2007-07-18 01:03 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Chistiakov 2007-07-05 12:43:51 UTC
Reproduced in build 200707050429.

This is a regression since M10.

To reproduce the bug:
- create a new XSLT Module;
- add a new XML Schema into the module;
- add a new global element 'E' of the xsd:string built-in type into the chema;
- start New WSDL Document wizard;
- do NOT explicitly import the schema, press Next button on 'File name And Location' pane;
- select 'E' element defined in the schema for both input and output elements, then press Next button;
- select Document Literal binding subtype and press Finish.
Vaildate the WSDL document. Validation fails because <types/> section of WSLD is empty.

In M10, if I use the same scenario, the schema file automatically imports to into WSDL.
Comment 1 Andrei Chistiakov 2007-07-05 12:50:58 UTC
Adding jskrivanek to CC as the issue blocks automatic commit validation tests against XSLT Editor.
Comment 2 Shivanand Kini 2007-07-06 21:33:02 UTC
Fixed this.
Comment 3 jlautz 2007-07-18 01:03:34 UTC
Verified fixed in 
Product Version: NetBeans IDE Dev (Build 200707161200) Java: 1.6.0_01; Java HotSpot(TM) Client VM 1.6.0_01-b06 System:
Windows XP version 5.1 running on x86; Cp1252; en_US (nb) Userdir: C:\Documents and Settings\lautz\.netbeans\dev


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo