Bug 108831 - deadlock while editing java code.
deadlock while editing java code.
Status: RESOLVED DUPLICATE of bug 110074
Product: java
Classification: Unclassified
Component: Source
6.x
Sun All
: P2 (vote)
: 6.x
Assigned To: Jan Lahoda
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-04 02:25 UTC by _ pcw
Modified: 2007-09-20 08:21 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (17.72 KB, text/plain)
2007-07-04 02:25 UTC, _ pcw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ pcw 2007-07-04 02:25:30 UTC
See attached stack dump, just locked up w/o warning, had to kill process to get dump.
Comment 1 _ pcw 2007-07-04 02:25:53 UTC
Created attachment 44697 [details]
thread dump
Comment 2 Jan Lahoda 2007-07-09 13:48:49 UTC
Sorry, I do not see any obvious (Java-level) deadlock in the thread dump. Some threads are waiting to lock object
0xd1c24ef0, which is not locked by any thread. AWT (also listed as waiting on 0xd1c24ef0) is even shown as RUNNABLE. If
it happens again, please try to get the thread dump using jstack with the "-m" parameter. Thanks.
Comment 3 Petr Nejedly 2007-07-23 13:01:29 UTC
Note that it can be a livelock and the thread dump was caught just after another cycle of unlocking 0xd1c24ef0, ot there
might be a heap space shortage which would slow down everything a lot.
Comment 4 Tomas Zezula 2007-09-20 08:21:46 UTC

*** This issue has been marked as a duplicate of 110074 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo