Bug 108534 - Deadlock when creating macro
Deadlock when creating macro
Status: RESOLVED DUPLICATE of bug 107656
Product: editor
Classification: Unclassified
Component: Settings
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-29 17:21 UTC by Pavel Buzek
Modified: 2007-11-05 13:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Full threaddump (31.30 KB, text/plain)
2007-07-03 09:44 UTC, Vitezslav Stejskal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Buzek 2007-06-29 17:21:48 UTC
I tried to use Editor Macro for the first time in NetBeans. I used the editor toolbar to start recording, the macro was
suppose to just delete the first character on every line, so I pressed Shift + Right, Delete, Down, then I press the
toolbar button to stop recording. Dialog pops up, I enter a name ("a") and a shortcut (Ctrl + BackQuote, i.e. this char:
'`'). The IDE froze. I killed the IDE, started again, did the same and got exactly the same result.
Comment 1 Jan Lahoda 2007-06-29 22:15:06 UTC
Could you please attach a full thread dump when the deadlock occurs? Thanks.
Comment 2 Vitezslav Stejskal 2007-07-03 09:44:26 UTC
Created attachment 44651 [details]
Full threaddump
Comment 3 Vitezslav Stejskal 2007-07-03 09:45:55 UTC
Reproducible in a dev build.
Comment 4 Vitezslav Stejskal 2007-07-03 12:43:14 UTC
The same situation as in issue #107656.

*** This issue has been marked as a duplicate of 107656 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo