Bug 10851 - [Win2K NB 3.2.15] Generated code from form does create invalid gridbagConstraints
[Win2K NB 3.2.15] Generated code from form does create invalid gridbagConstra...
Status: CLOSED DUPLICATE of bug 10831
Product: guibuilder
Classification: Unclassified
Component: Code
3.x
PC Windows ME/2000
: P1 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-30 00:53 UTC by javaiware
Modified: 2003-06-30 18:25 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description javaiware 2001-03-30 00:53:26 UTC
Hi,

When I set the layout of a panel to gridbag the all code but the declaration of 
the gridbagConstraints is created.

This is the code that was created:

        jLabel1.setText("ID:");
        gridBagConstraints4 = new java.awt.GridBagConstraints();
        gridBagConstraints4.gridx = 0;
        gridBagConstraints4.gridy = 0;
        gridBagConstraints4.insets = new java.awt.Insets(1, 1, 1, 1);
        gridBagConstraints4.anchor = java.awt.GridBagConstraints.EAST;
        tabCookies.add(jLabel1, gridBagConstraints4);

this is what should have been created:

        jLabel1.setText("ID:");
        java.awt.GridBagConstraints gridBagConstraints4;
        gridBagConstraints4 = new java.awt.GridBagConstraints();
        gridBagConstraints4.gridx = 0;
        gridBagConstraints4.gridy = 0;
        gridBagConstraints4.insets = new java.awt.Insets(1, 1, 1, 1);
        gridBagConstraints4.anchor = java.awt.GridBagConstraints.EAST;
        tabCookies.add(jLabel1, gridBagConstraints4);

Iwan
Comment 1 Svata Dedic 2001-03-30 05:58:40 UTC
Form generators, it could be your problem. If not, please reassign it back. Thx.
Comment 2 Tomas Pavek 2001-03-30 12:07:36 UTC
Same as issue #10831, already fixed.

*** This issue has been marked as a duplicate of 10831 ***
Comment 3 Quality Engineering 2003-06-30 18:20:57 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 4 Quality Engineering 2003-06-30 18:25:58 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo