Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 108485 - [push down method] PushDown a method referenced inside the same class where it is declared returns an erroneous mesage
[push down method] PushDown a method referenced inside the same class where i...
Status: RESOLVED DUPLICATE of bug 108482
Product: editor
Classification: Unclassified
Component: Refactoring
6.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: issues@java
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-29 01:06 UTC by kely_garcia
Modified: 2007-06-29 11:10 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kely_garcia 2007-06-29 01:06:45 UTC
Build ID: Netbeans 6.0 M9 (070502)

Steps To Reproduce:
Push down method m on the following returns an erroneous message: "cannot push down any members. The selected type has 
no subtypes". Instead it should return a warning like "Pushed down member A.m() is referenced by A.mPrime()"

public class A {
  public Object theField;
  public void m(){
  }
  void mPrime(){
    m();
  }
}
class B extends A {
}
Comment 1 Jan Becicka 2007-06-29 11:10:55 UTC

*** This issue has been marked as a duplicate of 108482 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo