Bug 108470 - need a way to browse Java API for generated web service interface
need a way to browse Java API for generated web service interface
Status: RESOLVED DUPLICATE of bug 120045
Product: webservices
Classification: Unclassified
Component: Code
6.x
PC Linux
: P3 (vote)
: TBD
Assigned To: bhate
issues@webservices
:
Depends on: 105645
Blocks: 154046
  Show dependency treegraph
 
Reported: 2007-06-28 22:21 UTC by billshannon
Modified: 2008-11-28 08:44 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description billshannon 2007-06-28 22:21:54 UTC
If I import a WSDL file and generate a web service client interface,
there seems to be no obvious way to browse the API of the generated
Java classes so that I can understand how to use the generated interface.
The only way I've figured out is to find the source code for the
generated classes and view each file in the editor.  What I'd really
like is some sort of javadoc-like interface to view the generated API.
Comment 1 Milan Kuchtiak 2008-11-10 12:41:26 UTC
The current ANT infrastructure doesn't allow this directly - without manual re-writing of javadoc task.
Comment 2 Milan Kuchtiak 2008-11-19 10:57:33 UTC
See the issue 120045.

*** This issue has been marked as a duplicate of 120045 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo