Bug 108446 - I18N - EntApp wizard doesn't resize properly to show all of its components
I18N - EntApp wizard doesn't resize properly to show all of its components
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: EAR
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Tomas Mysik
issues@javaee
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 17:16 UTC by kaa
Modified: 2007-07-25 15:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
image (78.76 KB, image/jpeg)
2007-06-28 17:18 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2007-06-28 17:16:32 UTC
Product Version: NetBeans IDE Dev (Build 200706230000)
Java: 1.6.0_01; Java HotSpot(TM) Client VM 1.6.0_01-b06
System:Windows XP version 5.1 running on x86; MS932; ja_JP (nb), fontsize 16
Resolution 1280x1024

1. Open New Project wizard
2. Select Enterprise category
3. Choose project type: Enterprise Application
4. Press Next button

The wizard will change its size. It is out of sreen boundaries.
On Solaris10 Sparc it doesn't happen. See attached image (labels are ok).

Assumption is that user does not need to manually resize most windows or dialogs to see all of the ui objects and
information in them. I'am running in pseudo localized locale in which each message/label is a bit longer than english to
account for that in some locales, translations result in longer strings than in english. Also am running at fontsize 16,
which is viewed as a valid font size that might be used. Resizing issues are not just related to i18n; they might show
to user in english locale if they run at larger fontsize.
Comment 1 kaa 2007-06-28 17:18:03 UTC
Created attachment 44534 [details]
image
Comment 2 Tomas Mysik 2007-07-25 10:19:25 UTC
In the attached screenshot I see that the width of the wizard is because of 'Project Folder' property - it seems that 
this property (path) is quite long - and this is probably the reason why you cannot reproduce it on Solaris. So - I 
can't see any valid solution here because I think that this is a corner case (the only solution I can think of now is 
to shorten this property but - what about other properties? and wouldn't it be strange for someone who has "high" 
resolution - wouldn't he/she ask why it is shortened?). So I suggest WONTFIX.
Adding Petr Blaha on CC because I've discussed this with him.
Comment 3 Ken Frank 2007-07-25 15:42:14 UTC
if its just project folder property that is the largest part, and can cause the problem, then it can be ok since that is
a textfield and can
be scrolled thru  - so no resize problems with that.

but in image it seemed that perhaps because proj text field or other part was trying to resize, that
button at bottom was not all shown.  that was why issue was filed.

so perhaps if that text field is not asked to resize (so much)  then the buttons at bottom will show all ?

ken.frank@sun.com


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo