Bug 108444 - I18N - localized jdk javadoc does not show in editor when user in ja locale
I18N - localized jdk javadoc does not show in editor when user in ja locale
Status: RESOLVED DUPLICATE of bug 99487
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P2 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 17:13 UTC by Ken Frank
Modified: 2007-07-24 15:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2007-06-28 17:13:47 UTC
am on solaris in ja locale

1. add the jdk6 ja javadoc zip to the java platform manager for the 1.6 jdk being used.

2. create a j2se project - in its library properties, this jdk is one selected is the java platform.
(there is no need to add this ja javadoc zip file elsewhere in the project properties.

3. go to the editor for the java program of this project

4. type Stri and then invoke code completion - choose String and its javadoc is shown.

5. but its the english javadoc that is shown, not the localized one.

6. if i unzip the ja javadoc and  use browser and go to String page, it is in Japansese looks to be the same as the en
javadoc seen during the code completion viewing of that javadoc popup.
Comment 1 Ken Frank 2007-06-28 17:22:59 UTC
should this be a separate issue ?

help->javadoc shows localized ja javadoc

but javadoc search window. when am in ja locale, shows just english javadoc

should the ja one be shown instead  - or should there be 2 entries ?

ken.frank@sun.com
Comment 2 Ken Frank 2007-06-29 04:18:02 UTC
on reviewing the last comment, realized it would be a separate issue - filed 108492.
Comment 3 Dusan Balek 2007-07-24 15:58:19 UTC
Already reported. Thanks.

*** This issue has been marked as a duplicate of 99487 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo