Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 108288 - Status not updated after reverting a deletion
Status not updated after reverting a deletion
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
Sun All
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 14:22 UTC by Padraig Obriain
Modified: 2008-02-07 15:18 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
proposed patch (1.07 KB, patch)
2008-02-07 14:46 UTC, Padraig Obriain
Details | Diff
additional patch (868 bytes, patch)
2008-02-07 15:17 UTC, Padraig Obriain
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Padraig Obriain 2007-06-27 14:22:25 UTC
At project node, choose Revert Modifications and choose a changeset before a file was created. 
This will cause this file to be Locally Removed. It disappears from the prject view but is listed in Status output.
In Status window, right click on the file and invoke "Revert "Delete".
The file reappears in the project view but it status remain as "Locally Removed".
Comment 1 Padraig Obriain 2007-06-27 15:29:46 UTC
This is working correctly for me now. 
Comment 2 novakm 2008-02-05 14:19:59 UTC
I can reproduce described behavior very easily. After Revert Modifications, deleted files are not displayed in Status
window until I invoke Refresh status. And after Revert Deleted or Revert Modifications to the latest revision, those
files are still in the Status Window until I invoke Refresh Status again.

Product Version: NetBeans IDE Dev (Build 200802040003)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows Vista version 6.0 running on x86; Cp1252; en_GB (nb)
Comment 3 Padraig Obriain 2008-02-07 14:24:02 UTC
This regression is caused by the change made for issue 123593. When I revert that change this problem no longer occurs.
Comment 4 Padraig Obriain 2008-02-07 14:46:22 UTC
Created attachment 56250 [details]
proposed patch
Comment 5 Padraig Obriain 2008-02-07 14:48:28 UTC
changeset:   66304:a4c1c81ea65b
tag:         tip
user:        padraigob@netbeans.org
date:        Thu Feb 07 14:45:37 2008 +0000
files:       mercurial/src/org/netbeans/modules/mercurial/ui/update/RevertModificationsAction.java
description:
108288: Undo change for issue #123593 as it causes this problem
Comment 6 Padraig Obriain 2008-02-07 15:17:35 UTC
Created attachment 56257 [details]
additional patch
Comment 7 Padraig Obriain 2008-02-07 15:18:15 UTC
changeset:   66343:7bb816d29ca0
tag:         tip
user:        padraigob@netbeans.org
date:        Thu Feb 07 15:15:10 2008 +0000
files:       mercurial/src/org/netbeans/modules/mercurial/ui/update/RevertModificationsAction.java
description:
108288: Fix typo in last commit



By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo