Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 108119 - project changes are lost during plugin deactivating or uninstalling
project changes are lost during plugin deactivating or uninstalling
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: General
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Yang Su
issues@uml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-26 10:43 UTC by Andrew Korostelev
Modified: 2007-09-06 07:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Korostelev 2007-06-26 10:43:52 UTC
If user has dirty uml project when uml plugin deactivation is started,
all changes will be lost.

Even suggestion to save diagram doesn't help, because if elements are not saved in the model, they will be automatically
removed from model.

reproducible with :
netbeans-6.0-nightly-200706251444-basic-windows.exe
UML 26.06.07 installed using UC.

steps:
- create java-model uml project
- create new diagram, put and name element on diagram
- DO NOT save anything.
- open plugins manager using 'Tools | Plugins'
- in 'Installed' tab select UML plugin.
- click deactivate button on plugin description page
- dialog with suggesion to save diaram will appear. Save changes.
- you will see exceptions in error manager ( issue 102226 )
- after deativation will be finished, activate module again.
- open project created on the first step.
BUG:
1) there is no element in the model tree
(=> it is removed from diagram)
2) 'Opening projects' status bar stops on 50%.
Comment 1 Andrew Korostelev 2007-06-26 16:16:21 UTC
see also issue 106024
Comment 2 Peter Lam 2007-06-29 22:53:01 UTC
Workaround:  Save the uml project which also saves all modified diagrams if any before deactivating or uninstalling the
UML plugin.
Comment 3 Yang Su 2007-07-06 20:08:11 UTC
Added logic to save modified uml projects and diagrams automatically when uml modules are uninstalled or 
deactivated.
Comment 4 Peter Lam 2007-09-06 07:32:14 UTC
verified in beta1 build 070905


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo