Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 107961 - Nokia Deployment Module - No module providing the capability org.openide.modules.os.Windows could be found.
Nokia Deployment Module - No module providing the capability org.openide.modu...
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: -- Other --
6.x
PC Linux
: P1 (vote)
: 6.x
Assigned To: Adam Sotona
issues@mobility
:
: 108057 (view as bug list)
Depends on:
Blocks: 104262
  Show dependency treegraph
 
Reported: 2007-06-25 09:03 UTC by Marian Mirilovic
Modified: 2007-06-29 13:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2007-06-25 09:03:28 UTC
NB Dev M10 (200706242201), JDK 1.5.0_12

Warning dialog rises after starting Full distribution :

Warning - could not install some modules:
        Nokia Deployment Module - No module providing the capability org.openide.modules.os.Windows could be found.
Comment 1 Peter Pis 2007-06-25 09:10:32 UTC
Changing dependency to Mobility M10 umbrella issue.
Comment 2 Martin Ryzl 2007-06-25 09:56:50 UTC
dependency set according to
http://www.netbeans.org/download/dev/javadoc/org-openide-modules/apichanges.html#enhanced-support-for-os-specific-modules-iz-50943

Jardo, shouldn't the message be supressed in such cases?
Comment 3 Jaroslav Tulach 2007-06-25 10:04:28 UTC
If I understand it right, there is a module, part of full distribution that runs only on Windows. And when starting 
the IDE warning dialog is shown.

That is the right behaviour.

You probably forgotten to make the module eager one. Look at core/applemenu which does similar trick but only on Mac.
Comment 4 Adam Sotona 2007-06-25 12:50:17 UTC
yes, I'll mark it eager
Comment 5 Adam Sotona 2007-06-25 12:58:03 UTC
fixed in trunk and release60-m10
Comment 6 Adam Sotona 2007-06-26 10:22:19 UTC
*** Issue 108057 has been marked as a duplicate of this issue. ***
Comment 7 Peter Pis 2007-06-28 16:52:04 UTC
Could you please verify this issue for the latest M10 build? Thanks.
Comment 8 Lukas Hasik 2007-06-29 13:55:03 UTC
v


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo