Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 107886 - Failed to generate JSR 172 Client on Ubuuntu
Failed to generate JSR 172 Client on Ubuuntu
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Web Services
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Michal Skvor
issues@mobility
:
Depends on:
Blocks: 104262
  Show dependency treegraph
 
Reported: 2007-06-22 20:15 UTC by pcmreddy
Modified: 2007-06-28 19:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
netbeans.log file (114.01 KB, text/plain)
2007-06-26 19:43 UTC, pcmreddy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pcmreddy 2007-06-22 20:15:56 UTC
Build 06/22/07 build on Ubuntu 7.04
with JDK 1.6

Create a mobile application.
try to add J2ME Webservice client using this WSDL
http://www.swanandmokashi.com/HomePage/WebServices/StockQuotes.asmx?WSDL

It adds only 2 files (StockQuotes.wsclient and StockQuotes.asmx.wsdl)
It did not added required client java files.

This is working fine on XP verified in 6/19 build.
Comment 1 pcmreddy 2007-06-26 19:43:39 UTC
Created attachment 44427 [details]
netbeans.log file
Comment 2 pcmreddy 2007-06-26 19:44:21 UTC
NPE exception while generating client.
See attached log file.
Comment 3 Michal Skvor 2007-06-27 15:39:03 UTC
Fixed. The problem was is in improper resolution of destination folder on Linux/Unix machines.
Comment 4 pcmreddy 2007-06-27 20:17:02 UTC
I tried with M10 build (06/27) on Ubuntu. It is still reproducible.
J2ME webservice client is not able to produce java files.
Comment 5 Michal Skvor 2007-06-28 08:18:22 UTC
Closing as fixed for now.
Comment 6 Peter Pis 2007-06-28 16:51:26 UTC
Could you please verify this issue for the latest M10 build? Thanks.
Comment 7 pcmreddy 2007-06-28 19:37:45 UTC
Verified in M10 on 6/28.
Working as expected.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo