Bug 10777 - IDE executes code during creation
IDE executes code during creation
Status: CLOSED WORKSFORME
Product: ide
Classification: Unclassified
Component: Code
-FFJ-
Sun Solaris
: P1 (vote)
: TBD
Assigned To: issues@www
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-28 15:46 UTC by Ivana Ladenbergerova
Modified: 2005-03-09 04:28 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
ide.log (6.11 KB, text/plain)
2001-03-28 15:47 UTC, Ivana Ladenbergerova
Details
a copy of my code (434.28 KB, application/octet-stream)
2001-03-30 15:01 UTC, Ivana Ladenbergerova
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivana Ladenbergerova 2001-03-28 15:46:15 UTC
Another damned bug, this is torture.
Once again it deals with the IDE trying to execute code during creation.
I have a JTree component that accesses a Servlet to fill some of the tree nodes.
When I made the change to the JTree to implement this code.
The IDE crapped out.
Not only that, but it removed all references to the JTree panel from all my 
other panels.
This started a chain reaction of failed classes.
Essentially my application was wiped out.
I will have to recover from backup.
I've done some exeprimenting and this is what I see.
WHen I try to add the JTree to a panel the IDE trys to execute the code that 
accesses the
Servlet.
If I provide the login info everything goes fine.
But I don't want to have to do that.
I don't wan the code to execute until I start the application, when I will be 
logged in.
The work around I beleive is to have the JTree fill in only after the tree is 
diplayed for
the first time.
But that sucks.
Also the big issue was the IDE destroying existing code, because it couldn't 
compile some
classes.
It should give me a chance to fix them, without removing all refences to the 
classes.
All my classes and forms wiped out!
I'm off to recover from backup.
Comment 1 Ivana Ladenbergerova 2001-03-28 15:47:34 UTC
Created attachment 907 [details]
ide.log
Comment 2 Jan Zajicek 2001-03-29 08:28:35 UTC
Huh, I have to say, that I do not clearly understand the described process.
The description is a little bit misunderstood. Moreover I am not sure where is
the bug, if on our side or on JSP side. Please, describe step by step (in
details), what we have to do to reproduce it and attach the mentioned example. 
Comment 3 Ivana Ladenbergerova 2001-03-30 14:56:27 UTC
I have attached the latest copy of my code.

Note:
1. This version of the code has the work-around I mentioned in place, so you 
won't see the
problem initially.
2. This code is aimed at our network environment and probably won't run well if 
at all
anywhere else.
3. To run this code requires Tomcat and installation of the nmcseadmin.war file 
into
Tomcat.
4. To see the problem you don't actually have to run it, you just need to open 
it in the
IDE.
5. Below are instructions to see the problem and another description of the 
problem.

Description of the problem:
1. The "real problem" is that the IDE removes the NmcseAdminTree class from the
NmcseAdminTool .form and .java files.  I assume that it does this because it 
can not
resolve the NmcseAdminTree class, due to the attempt to execute the new code.
2. I don't like the IDE attempting to execute my code unless I tell it to.  The 
IDE should
only try to read the .forms files to display the GUI (right?).
3. I state again the IDE should never remove lines of code, especially ones 
that I've
added, without asking me first.

More description:
The first time I saw the problem was after I added the new code.
At this time the new code, the buildDynamicBranches code, was directly in the
NmcseAdminTree constructor.
I didn't even realize the IDE had removed the NmcseAdminTree class referneces, 
until I went
into NmcseAdminTool to make additonal calls to pass the cookie info to 
NmcseAdminTree.
It was then that I realized what the IDE had done.
It had the NmcseAdminTree class from the NmcseAdminTool .form and .java files.
At that time I tried to copy the NmcseAdminTree back into the NmcseAdminTool, 
but the IDE
got a NullPointer exception and said I should let you guys know.
The details informed me that it was trying to execute the new code and was 
failing.

Instructions to see the problem:
To see the "bug" I am talking about simply open the 
gui/trees/NmcseAdminTree.java file.
Add a call to buildDynamicBranches to the only constructor just following the 
call to
initComponents.
Save the file.
The cookie info can be a blank string for this demo.
The problem may appear immediately, but if not, close and re-open the project.
Comment 4 Ivana Ladenbergerova 2001-03-30 15:01:05 UTC
Created attachment 925 [details]
a copy of my code
Comment 5 Jan Zajicek 2001-04-04 12:11:50 UTC
Marek as a jsp qa guru ;-) will examine this bug.
Comment 6 Marek Fukala 2001-04-04 12:57:03 UTC
I'm not absolutely sure, but this bug seems NOT to be related with web module. 
It looks as a bug in form editor or java module. I have tried to reproduce it, 
but unfortunately I was unable to get the bug which is described.
Comment 7 Jan Zajicek 2001-04-06 14:32:27 UTC
I tried thoroughly check the problem in the NB3.2 build #22 and everything works
well for me. So I please sustaining to check if the problem persist in FFJ2.0.
If the problem exist it is not in JSP but may be somewhere between form and
core, but I was unable to reproduce it in the latest build of NetBeans 3.2.
Comment 8 Jan Chalupa 2003-07-07 13:58:02 UTC
Obsolete issue resolved for 3.4 or earlier. Marking as VERIFIED, will CLOSE shortly.
Comment 9 Jan Chalupa 2003-07-07 13:59:41 UTC
Closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo