Bug 107656 - Deadlock in CustomizableSideBar
Deadlock in CustomizableSideBar
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
: THREAD
: 108534 109798 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-21 15:16 UTC by Tomas Mysik
Modified: 2007-11-05 13:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (20.68 KB, text/plain)
2007-06-21 15:17 UTC, Tomas Mysik
Details
Similar threads dump (17.39 KB, text/plain)
2007-07-03 10:51 UTC, pzajac
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2007-06-21 15:16:45 UTC
see attachment
Comment 1 Tomas Mysik 2007-06-21 15:17:44 UTC
Created attachment 44179 [details]
thread dump
Comment 2 pzajac 2007-07-03 10:51:55 UTC
Created attachment 44659 [details]
Similar threads dump
Comment 3 pzajac 2007-07-03 10:53:56 UTC
[070703] The deadlock occured on closing Options panel. 
Comment 4 Vitezslav Stejskal 2007-07-03 12:43:14 UTC
*** Issue 108534 has been marked as a duplicate of this issue. ***
Comment 5 Vitezslav Stejskal 2007-07-03 14:54:01 UTC
Should be fixed.

Checking in src/org/netbeans/modules/editor/NbEditorUI.java;
/cvs/editor/src/org/netbeans/modules/editor/NbEditorUI.java,v  <--  NbEditorUI.java
new revision: 1.67; previous revision: 1.66
done
Checking in src/org/netbeans/modules/editor/impl/CustomizableSideBar.java;
/cvs/editor/src/org/netbeans/modules/editor/impl/CustomizableSideBar.java,v  <--  CustomizableSideBar.java
new revision: 1.7; previous revision: 1.6
done
Checking in libsrc/org/netbeans/editor/GlyphGutter.java;
/cvs/editor/libsrc/org/netbeans/editor/GlyphGutter.java,v  <--  GlyphGutter.java
new revision: 1.54; previous revision: 1.53
done
Comment 6 Vitezslav Stejskal 2007-07-18 12:36:26 UTC
*** Issue 109798 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo