Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 107526 - Cannot Deploy application after a new page is added
Cannot Deploy application after a new page is added
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Sun Appserver 9
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-20 22:08 UTC by Yousuf Haider
Modified: 2007-08-02 18:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Console Output (2.44 KB, text/plain)
2007-06-20 22:08 UTC, Yousuf Haider
Details
Server Output (5.83 KB, text/plain)
2007-06-20 22:10 UTC, Yousuf Haider
Details
I see this exception from the console (2.05 KB, text/plain)
2007-06-20 22:27 UTC, _ potingwu
Details
I also see "Cant copy Serializable object" in the server.log (59.43 KB, application/octet-stream)
2007-06-20 22:32 UTC, _ potingwu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Haider 2007-06-20 22:08:17 UTC
Build:200706201745
JDk: Both 1.5.0_10 and 1.6
Glassfish v2b50

Steps to reproduce:
1. Create new VW project with target server as glassfish.
2. Run application.
3. Add a new VW JSF page to the project
4. Run project again.
5. Deployment will fail with the following error on console: (full output attached)

Building jar: C:\Documents and Settings\USER\Desktop\sample rojects\WebApplication44\dist\WebApplication44.war
do-dist:
dist:
Incrementally deploying WebApplication44_localhost:4848_server
Error during incremental deploy: org.netbeans.modules.masterfs.filebasedfs.utils.FSException: Cannot create file
Page3.class in folder C:/Documents and Settings/USER/Desktop/sample
rojects/WebApplication44/build/web/WEB-INF/classes/webapplication44. This file already exists.
C:\Documents and Settings\USER\Desktop\sample rojects\WebApplication44\nbproject\build-impl.xml:526: Deployment error:
null
See the server log for details.
BUILD FAILED (total time: 3 seconds)

6. Server log shows no problems (attached).


Run application again and it will be deployed fine.
Comment 1 Yousuf Haider 2007-06-20 22:08:56 UTC
Created attachment 44113 [details]
Console Output
Comment 2 Yousuf Haider 2007-06-20 22:10:31 UTC
Created attachment 44114 [details]
Server Output
Comment 3 _ potingwu 2007-06-20 22:27:57 UTC
Created attachment 44115 [details]
I see this exception from the console
Comment 4 _ potingwu 2007-06-20 22:31:36 UTC
Looks like the failure is caused by org.netbeans.modules.j2ee.deployment. (see attached messages.log)

I also see "java.lang.RuntimeException: Cant copy Serializable object" in the server log.
Comment 5 _ potingwu 2007-06-20 22:32:35 UTC
Created attachment 44117 [details]
I also see "Cant copy Serializable object" in the server.log
Comment 6 Vince Kraemer 2007-06-26 01:23:24 UTC
I have reproduced this issue and have a hack of a fix.  The real fix will need some more thought...

It seems like the class file for a new page "appears" after the code thinks that it should...

The issue is really in j2eeserver/.../ServerFileDistributor.java...
Comment 8 Yousuf Haider 2007-08-02 18:32:16 UTC
Verified on : 200708011200


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo