Bug 107232 - Deadlock at .editor.hints.AnnotationHolder
Deadlock at .editor.hints.AnnotationHolder
Status: RESOLVED DUPLICATE of bug 107402
Product: editor
Classification: Unclassified
Component: Hints & Annotations
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jan Lahoda
issues@editor
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 15:10 UTC by Martin Schovanek
Modified: 2007-11-05 13:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thred Dump (19.85 KB, text/plain)
2007-06-19 15:10 UTC, Martin Schovanek
Details
Correct Thread Dump (31.87 KB, text/plain)
2007-06-19 15:39 UTC, Martin Schovanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schovanek 2007-06-19 15:10:06 UTC
[#200706180000, jdk1.5.0]

Reproducible by Aut Tests where:
org.netbeans.editor.BaseDocument.insertString(...) is called outside AWT-EventQueue, see:
http://www.netbeans.org/source/browse/*checkout*/web/jspsyntax/test/qa-functional/src/org/netbeans/test/web/core/syntax/AutoCompletionTest.java?rev=1.5
Comment 1 Martin Schovanek 2007-06-19 15:10:35 UTC
Created attachment 43968 [details]
Thred Dump
Comment 2 Jan Lahoda 2007-06-19 15:25:33 UTC
Sorry, but I do not see how is this related to AnnotationHolder - it is nowhere in the thread dump.
Comment 3 Martin Schovanek 2007-06-19 15:39:56 UTC
Created attachment 43972 [details]
Correct Thread Dump
Comment 4 Martin Schovanek 2007-06-19 15:43:51 UTC
Sorry, I attached wrong TD. Please see the Correct Thread Dump.
Comment 5 Jan Lahoda 2007-06-19 15:51:58 UTC
Ok, thanks. I will try to fix for M10.
Comment 6 Jan Lahoda 2007-06-25 16:50:06 UTC
Also reported as issue #107402.

*** This issue has been marked as a duplicate of 107402 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo