Bug 107103 - I18N - global encoding not shown for freeform ant project
I18N - global encoding not shown for freeform ant project
Status: RESOLVED INVALID
Product: projects
Classification: Unclassified
Component: Ant Freeform
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Milan Kubec
issues@projects
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 00:12 UTC by Ken Frank
Modified: 2007-06-20 13:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2007-06-19 00:12:45 UTC
97854 was on implementing feq for new project encoding property
for freeform projects

for a new java  project from existing source with ant script,
the wizard shows the global encoding value
(in this case its been changed by a previous project to not be utf-8)

the encoding choice in the wizard is not changed.

but after the project is created and opened, the encoding properties
shows "no encoding" rather than the encoding that is the current
global value and that was not changed when doing the wizard.

this does not happen for a new java  project with existing sources.


Other question - for web and enterprise and other projects that have choices for create a project using existing sources
with or without ant scripts - 
- is the implementation and use of global encoding property the same code in the same module as for the java ones, or
is it implemented separately by each project ?
Comment 1 Milan Kubec 2007-06-19 11:26:18 UTC
When creating the project - did you select any source package folder? Because encoding is bound with package folder and
if the project doesn't have any package folder there is no encoding. Please verify that. I'm not able to reproduce when
selecting some folder as package root.
Comment 2 Ken Frank 2007-06-19 16:00:11 UTC
Yes, when selecting src folders for the project, the global encoding is shown ok.

If its the typical use that src folders would be chosen then this issue can be closed.

ken.frank@sun.com
Comment 3 Milan Kubec 2007-06-20 08:32:08 UTC
Yes, it's required to select any folder to actually safe project encoding, because the encoding is bound to folder.
Closing as invalid.
Comment 4 Milan Kubec 2007-06-20 13:22:52 UTC
To your question - each project type implements its own file encoding handling.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo