Bug 106840 - Some components are not resizable
Some components are not resizable
Status: RESOLVED DUPLICATE of bug 95022
Product: obsolete
Classification: Unclassified
Component: visualweb
6.x
PC Windows XP
: P1 (vote)
: TBD
Assigned To: Winston Prakash
issues@obsolete
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-15 16:25 UTC by Roman Mostyka
Modified: 2007-06-15 16:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Mostyka 2007-06-15 16:25:37 UTC
1. Create Java EE 5 Web Application with "Visual Web JSF" framework.
2. Add Text Field component.
3. Try to resize it.

Result: Component is not resizable.
The same with some other components: Text Area, Drop Down List, List Box. Probably it happens with all components that
are inherited from text field.
Comment 1 Lark Fitzgerald 2007-06-15 16:53:03 UTC
This is not a bug.  This is a functional change.  Please use the property sheet settings for column to change the width
of the component and style for size.

Here's the release note blurb:

http://www.netbeans.org/issues/show_bug.cgi?id=95022

    Description: Due to a change in Woodstock components, resize handles have been removed from the following Woodstock
components: TextField, TextArea,PasswordField, DropDown and ListBox. This issue impacts especially projects imported
from Java Studio Creator and NetBeans Visual Web Pack 5.5/5.5.1. Resized components may look different from how they
looked in previous releases.

    Workaround: For TextField and TextArea components, use the columns and rows attributes, respectively. DropDown and
ListBox components are automatically resized to the size of the longest item by the browser.


*** This issue has been marked as a duplicate of 95022 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo