Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 106724 - Performance: Visualweb designer crawls while designing complex pages
Performance: Visualweb designer crawls while designing complex pages
Status: RESOLVED DUPLICATE of bug 105179
Product: obsolete
Classification: Unclassified
Component: visualweb
6.x
All All
: P2 (vote)
: TBD
Assigned To: Peter Zavadsky
issues@obsolete
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 22:03 UTC by Winston Prakash
Modified: 2007-06-25 18:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Call tree for designer painting performance (871.10 KB, application/octet-stream)
2007-06-14 22:06 UTC, Winston Prakash
Details
Designer painting hot spots (399.66 KB, application/octet-stream)
2007-06-14 23:50 UTC, Winston Prakash
Details
Sample Project (176.81 KB, application/octet-stream)
2007-06-15 00:27 UTC, Winston Prakash
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Winston Prakash 2007-06-14 22:03:29 UTC
This bug report is based on the VWP performance tiger team observation.
When a complex page is loaded in to the designer, it becomes very cumbersome
to design the page.

While moving around the components or modifying the component properties 
it takes several second for the designer to repaint. Designer freezes for
several seconds

On a fast machine it takes about 7-10 seconds for designer refresh.
On a slow end machine, it takes about 30-40 seconds on a very complex page.

We analyzed the performance using The main culprit seems to be
org.apache.batik.css.engine.CSSEngine.getCascadedStyleMap. (see attachments). 
For every property change in the component the StyleMap is recomputed by batik 
parser which is the main performance bottle neck.   

Even when one property changes other computed properties in the parents and children 
(inheritance + cascading) might change. so most of the things get recomputed after that.
  
Is there a way not to do page layout when modifications made to properties which does
not influence the layout at all (e.g renaming the id) or doing a binding that does not
change the visual at all.
Comment 1 Winston Prakash 2007-06-14 22:06:19 UTC
Created attachment 43740 [details]
Call tree for designer painting performance
Comment 2 Winston Prakash 2007-06-14 23:50:54 UTC
Created attachment 43748 [details]
Designer painting hot spots
Comment 3 Winston Prakash 2007-06-15 00:27:22 UTC
Created attachment 43756 [details]
Sample Project
Comment 4 Winston Prakash 2007-06-23 00:25:14 UTC
Also refer bug
http://www.netbeans.org/issues/show_bug.cgi?id=105179
Comment 5 Peter Zavadsky 2007-06-25 18:42:28 UTC
OK, it seems it is the same issue, making it a duplicate.

*** This issue has been marked as a duplicate of 105179 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo