Bug 106456 - ISE from keymap options
ISE from keymap options
Status: RESOLVED DUPLICATE of bug 126355
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Skrivanek
issues@platform
: RANDOM, THREAD
: 107321 109201 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 06:12 UTC by _ tboudreau
Modified: 2008-12-22 14:38 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2007-06-13 06:12:43 UTC
Caused by rapidly clicking twice somewhere in the options dialog (or maybe the main window?) as the options dialog was initializing.

Technically the bug may be that CloneDocumentAction should not expect only to be constructed on the AWT thread.

java.lang.IllegalStateException: Assertion failed. WindowsAPI is required to be called from AWT thread only, see http://core.netbeans.org/proposals/
threading/
	at org.netbeans.core.windows.WindowManagerImpl.assertEventDispatchThreadWeak(WindowManagerImpl.java:1432)
	at org.netbeans.core.windows.WindowManagerImpl.topComponentID(WindowManagerImpl.java:1178)
	at org.openide.windows.WindowManager.findTopComponentID(WindowManager.java:491)
	at org.netbeans.core.windows.model.TopComponentSubModel.getID(TopComponentSubModel.java:348)
	at org.netbeans.core.windows.model.TopComponentSubModel.containsTopComponent(TopComponentSubModel.java:238)
	at org.netbeans.core.windows.model.DefaultModeModel.containsTopComponent(DefaultModeModel.java:238)
	at org.netbeans.core.windows.model.DefaultModel.containsModeTopComponent(DefaultModel.java:777)
	at org.netbeans.core.windows.Central.containsModeTopComponent(Central.java:1401)
	at org.netbeans.core.windows.ModeImpl.containsTopComponent(ModeImpl.java:342)
	at org.netbeans.core.windows.WindowManagerImpl.findMode(WindowManagerImpl.java:402)
	at org.netbeans.core.windows.actions.CloneDocumentAction.updateEnabled(CloneDocumentAction.java:74)
	at org.netbeans.core.windows.actions.CloneDocumentAction.<init>(CloneDocumentAction.java:46)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
	at java.lang.Class.newInstance0(Class.java:350)
	at java.lang.Class.newInstance(Class.java:303)
	at org.openide.loaders.InstanceSupport.instanceCreate(InstanceSupport.java:197)
	at org.openide.loaders.InstanceDataObject$Ser.instanceCreate(InstanceDataObject.java:1192)
	at org.openide.loaders.InstanceDataObject.instanceCreate(InstanceDataObject.java:695)
	at org.netbeans.modules.options.keymap.LayersBridge.createAction(LayersBridge.java:344)
	at org.netbeans.modules.options.keymap.LayersBridge.initActions(LayersBridge.java:134)
	at org.netbeans.modules.options.keymap.LayersBridge.initActions(LayersBridge.java:98)
	at org.netbeans.modules.options.keymap.LayersBridge.getActions(LayersBridge.java:78)
	at org.netbeans.modules.options.keymap.KeymapModel.getActionCategories(KeymapModel.java:63)
	at org.netbeans.modules.options.keymap.KeymapModel.<init>(KeymapModel.java:312)
	at org.netbeans.modules.options.keymap.KeymapViewModel.<init>(KeymapViewModel.java:65)
	at org.netbeans.modules.options.keymap.KeymapPanel.getModel(KeymapPanel.java:332)
	at org.netbeans.modules.options.keymap.KeymapPanelController.getLookup(KeymapPanelController.java:63)
	at org.netbeans.modules.options.CategoryModel$Category.getLookup(CategoryModel.java:385)
	at org.netbeans.modules.options.CategoryModel$Category.access$000(CategoryModel.java:274)
	at org.netbeans.modules.options.CategoryModel$1.run(CategoryModel.java:63)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:539)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:964)
Comment 1 rmatous 2007-06-29 16:59:33 UTC
*** Issue 107321 has been marked as a duplicate of this issue. ***
Comment 2 rmatous 2007-07-10 09:45:03 UTC
*** Issue 109201 has been marked as a duplicate of this issue. ***
Comment 3 rmatous 2007-07-16 14:51:32 UTC
Method getLookup doesn't need to be called from AWT thread, javadoc for OptionsPanelController now mentions it see #106989
Comment 4 Vitezslav Stejskal 2007-07-25 12:46:04 UTC
I've seen this several times too. It usually happens when clicking Tools-Options right after starting the IDE.
Comment 5 Lukas Hasik 2008-04-10 21:21:39 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 6 Antonin Nebuzelsky 2008-04-15 17:00:50 UTC
Reassigning to new module owner jskrivanek.
Comment 7 Jiri Skrivanek 2008-09-11 15:20:43 UTC

*** This issue has been marked as a duplicate of 126355 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo