Bug 106438 - I18N - cvs - multibyte not shown correctly by view revision or diffs windows
I18N - cvs - multibyte not shown correctly by view revision or diffs windows
Status: RESOLVED DUPLICATE of bug 85257
Product: versioncontrol
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-12 23:32 UTC by Ken Frank
Modified: 2007-06-13 09:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
image (11.26 KB, image/gif)
2007-06-12 23:34 UTC, Ken Frank
Details
image (25.25 KB, image/gif)
2007-06-12 23:35 UTC, Ken Frank
Details
image (22.71 KB, image/gif)
2007-06-12 23:35 UTC, Ken Frank
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2007-06-12 23:32:17 UTC
unning in ja locale and using multibyte in j2se project  java class name and data, which is legal.

am not changing the default utf-8 project encoding (new feature for nb6)
(its utf-8 but it still shows chars ok of the default locale user is in when running
ide, which is the system locale; for me its solaris ja locale which is euc encoding.

showing the cvs view revisions or  diff window, the multibyte is not shown correctly; compare with right side of gif
which is correct - see attachmens for original file view which has the correct mbyte for reference, and the view
revisions and diff windows - which shows both correct and incorrect mbyte.

I am guessing that some changes/assumptions related to the feq implenentation might have caused this problem
in that cvs module code might be assuming euc-jp encoding vs utf8.

the reason for this guess is that, if change the project encoding to euc-jp, create a new java file, and use mbyte,
the local history left side is same as right side and shows correct multibyte.


clarification on the proj encoding property - user should not need to change it for default
case which is, they are in some locale when running ide and using the characters of that locale
in files - those chars should be shown correctly.
Comment 1 Ken Frank 2007-06-12 23:33:35 UTC
can you check shared code and see if this would be a problem also on subversion and file issue if so ?
I dont have a solaris version of subversion.

ken.frank@sun.com
Comment 2 Ken Frank 2007-06-12 23:34:40 UTC
Created attachment 43579 [details]
image
Comment 3 Ken Frank 2007-06-12 23:35:17 UTC
Created attachment 43580 [details]
image
Comment 4 Ken Frank 2007-06-12 23:35:45 UTC
Created attachment 43581 [details]
image
Comment 5 Tomas Stupka 2007-06-13 09:35:55 UTC

*** This issue has been marked as a duplicate of 85257 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo